Macbook Pro and iPad 2 won't connect to home wifi anymore

Discussion in 'MacBook Pro' started by daveme214, Jun 16, 2012.

  1. daveme214 macrumors newbie

    Joined:
    Jun 16, 2012
    #1
    Good morning...sorry if this is the wrong place to post...could use some help, though.

    I have an iPad 2 and a Macbook Pro, bought in November 2011 and March 2012, respectively. Had no problems with Wifi in the months of ownership using my Belkin router.

    We went on vacation last week, and used the Wifi in the house we were staying in with no problems (my Apple products and my wife's Windows laptop). When we returned, however, neither the iPad nor the Macbook will connect to the internet. Wife's PC connects/works just fine.

    I've rebooted everything (router, cable modem, iPad, Macbook) several times, and I've tried deleting the Wifi from the network locations and letting it re-locate it, to no avail. I also tried resetting the PRAM based on another post I saw. Still no love.

    When I run the diagnostics through the network settings, it shows the Wifi and the Wifi settings as green, the network settings as yellow, the ISP as green, and the internet and the server as red.

    Any advice/help would be appreciated...it's getting frustrating.

    Dave
     
  2. ethereal45 macrumors regular

    Joined:
    Oct 12, 2007
    #2
    I'm not a network expert, but to point out the obvious, I would be looking to your network configuration settings vs. thinking there is something wrong with your Apple products has gone awry.

    There's just no way they would both lose connectivity at the same time.
     
  3. jhuang macrumors member

    Joined:
    Jun 17, 2010
    #3
    It does sound like a network problem... but for what it's worth, when I visit my parents' house I have so many problems with my MacBook and their iPad while the PCs work just fine. We actually just took the iPad in to the Apple Store for not being to hold wifi connection anywhere, actually.
     
  4. daveme214 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
    #4
    The frustrating part is that they worked just fine here at the house, and they worked just fine at the vacation house. As soon as we got home, I tried to get online, and neither of them connect. They both recognize my network, but they won't connect.

    Meanwhile, my wife is giggling at me with her perfectly fine PC.
     
  5. malman89 macrumors 68000

    Joined:
    May 29, 2011
    Location:
    Michigan
    #5
    Maybe they're oddly prioritizing or trying to connect to the old network? Perhaps try to delete the old network and try connecting. I see you've already deleted your home network, but not sure if you removed the vacation one too.
     
  6. daveme214 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
    #6
    Malman...thanks for the reply. The only networks showing up are mine and my neighbor's. His signal is barely there, so I can't connect to that one (probably couldn't have even before I had this problem).
     
  7. daveme214 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
    #7
    Follow-up:

    Just got the network up and running again. I found some info on the Apple support site that I hadn't seen before. It was one of these two (I didn't check after the first action):
    - Disabled WPA and then re-enabled it
    - Changed the bandwidth setting on my router from 20/40MHz to 20 MHz. The Apple support site says the devices don't support the 40MHz mode.

    After those two actions, I restarted the router, and bam...here I am again.

    Anyway, just wanted to post the fix action(s) in case someone else runs across this problem. Not sure why this worked; none of my router settings have been touched in almost a year, and everything worked.

    Thanks for the responses!
     
  8. funnoam macrumors member

    Joined:
    Aug 7, 2011
    #8
    Strange, I got one iPad and one Macbook running without issues on 802.11n 40mhz wifi, and network speed is great.

    Nice to see it worked btw, sometimes wifi can be very annoying.
     
  9. hookooekoorider macrumors newbie

    Joined:
    Jan 7, 2016
    #9
    Thanks for posting this solution! I think it was the second thing you did that worked. I had the same problem with my Macbooks (newer ones) and iPhone 5s not being able to connect to my router (even though they could before), even though they recognized the wifi network. My solution was the reverse of yours though; I changed my bandwidth setting from 20 MHz to 20/40 MHz, without restarting the router, and that did the trick.


     

Share This Page