Macbook Pro and iPhone 7 unable to AirPlay to Apple TV3

Discussion in 'Apple TV and Home Theater' started by MitzEclipse, Oct 6, 2018.

  1. MitzEclipse macrumors member

    Joined:
    Sep 26, 2012
    #1
    Hi all

    For some reason I cannot AirPlay my Macbook Pro and iPhone 7 to my Apple TV3. Used to be able to AirPlay before - not sure why?

    Has there been a change since upgrading OS?

    OS Versions:
    MacBook Pro 2016: 10.13.6
    iPhone 7: iOS 12
    Apple TV3: 7.2.2

    I can SEE the Apple TV3, but when I click to AirPlay it looks like it's going to work then times out with an error "unable to connect to apple tv"

    Any suggestions?
     
  2. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #2
    I have a really old Panasonic AirPlay device and to be honest I’ve been a little surprised it still works.

    I stream to it from my iOS 12 iPhone 7 and my MacBook Pro running 10.14 Mojave.

    I don’t have an AppleTV though, sorry.

    Can you backup the AppleTV and try to stream to it as a freshly initialized device?
     
  3. waw74 macrumors 68040

    Joined:
    May 27, 2008
    #3
    try rebooting your router

    if that doesn't work, try googling airplay and your router number

    it's been a while, but there was a setting on mine that was interfering, i think it was WMM
     
  4. MitzEclipse thread starter macrumors member

    Joined:
    Sep 26, 2012
    #4
    tried rebooting router/modem as well as apple time capsule - still doesn't work - any other suggestions?
     
  5. Johnelf macrumors newbie

    Joined:
    Oct 7, 2018
    Location:
    Surrey Uk
    #5
    I had same issue after IOS 12 update
    Unplug your ATV from the mains, then power it back up and I think that will fix your issue.
    John
     
  6. MitzEclipse thread starter macrumors member

    Joined:
    Sep 26, 2012
    #6
    Just tried that again...still doesn't work - same issue....!!
     
  7. MitzEclipse thread starter macrumors member

    Joined:
    Sep 26, 2012
    #7
    OK got it to work. I was indeed connected to the same network but the issue was that I was connected via Ethernet. I changed to connect via Wifi and AirPlay started to work straight away. Very odd considering the Ethernet cable is connected directly to the TimeCapsule, which is providing the Wifi network. All good now. Cheers
     

Share This Page

6 October 6, 2018