MacBook Pro Video Glitches When Full-Screen in Safari

iPetrie

macrumors newbie
Aug 9, 2019
4
0
I have the same issue as well on my MacBook Pro (Retina, 13-inch, Early 2015). When I watch YouTube in fullscreen mode, there are flickers on the screen. By the way, I use Safari. And I also noticed that this happens only when watching YouTube, because even if I watch the same video on some other website — everything seems to be fine. I've been just looking for a way to solve this problem and thus come across this webpage. So does anyone has a solution or at least any advice maybe?
Since I wrote my previous post here, things have got even worse for me. Now those glitches and flickering of display happen absolutely randomly, not only when I watch videos on YouTube. I really hope that Apple will fix this issue with the next update of MacOS, otherwise I'll probably have to take my MacBook to a repair centre.
Guys, it seems that since I updated MacOS to Catalina version 10.15, I no longer see (or at least notice) any glitches and screen flickering. I'll let you know if those artifacts happen again, but hopefully they won't.
 

tyhenry

macrumors newbie
Feb 13, 2019
10
3
* ** *, * ** ** ** ** ** ** *
I also get random screen flickering/glitching that's prominent near the bottom of my screen. I've only noticed it whilst using Chrome/youtube but I haven't opened any other app besides chrome to check if it happens elsewhere.
Does the issue still persist on Catalina for you?
For me, it happens only on NETFLIX with closed caption on.
 

Islam_filali

macrumors newbie
Nov 6, 2019
4
1
maroc
hello im new here, and i have the same problem in macos catalina, that’s happened only in safari, i have macbook pro 2019 intel iris graphics 655, but i haven’t seen someone have this problem in catalina, you are the only person who talk about this.
Does the issue still persist on Catalina for you?
For me, it happens only on NETFLIX with closed caption on.
 
  • Like
Reactions: tyhenry

tyhenry

macrumors newbie
Feb 13, 2019
10
3
* ** *, * ** ** ** ** ** ** *
hello im new here, and i have the same problem in macos catalina, that’s happened only in safari, i have macbook pro 2019 intel iris graphics 655, but i haven’t seen someone have this problem in catalina, you are the only person who talk about this.
https://www.reddit.com/r/macbookpro/comments/dozlyb
I posted a recording of my situation here. plan to go to Apple Store tomorrow to see if they can help me with this.
 
  • Like
Reactions: Islam_filali

bmsarkes

macrumors newbie
Nov 8, 2019
1
0
I was having this issue as well. I only use Google Chrome, I have not tried it in other browsers. I thought it could have possibly been water damage to the screen. Turns out all I had to do was stick a sticker covering up my webcam and NO MORE GLITCHES while watching fullscreen. Funny how that worked out, still don't really know what the cause of it was though. Hope this helps.
 

Islam_filali

macrumors newbie
Nov 6, 2019
4
1
maroc
I was having this issue as well. I only use Google Chrome, I have not tried it in other browsers. I thought it could have possibly been water damage to the screen. Turns out all I had to do was stick a sticker covering up my webcam and NO MORE GLITCHES while watching fullscreen. Funny how that worked out, still don't really know what the cause of it was though. Hope this helps.
nice idea, because you close the sensor of truetone or brightness, but i gonna use it to see, thanks for the help
 

Rodrigo De la Castilleja

macrumors newbie
Jan 23, 2020
1
1
It seems is a problem with the color profiles, I deleted all from /system/Library/ColorSync/Profiles and now with the the default profile "Color LCD" subtitles works without artifacts
 
Last edited:
  • Like
Reactions: CPx