Macbook pro won't connect to internet all of a sudden

Discussion in 'MacBook Pro' started by zxin, Aug 6, 2009.

  1. zxin macrumors newbie

    Aug 6, 2009

    I just updated to 10.5.8, and now my internet doesn't work.

    I can connect to my wifi but no webpages will load and I can't ping google. I am connected to the same wifi network as the one I am typing this message from on my iMac.

    Anyone else having this issue?
  2. t0mat0 macrumors 603


    Aug 29, 2006
    Have you checked the net connection for the network itself, by going on say the wireless router's homepage, or looking at the lights?
    I'd heard some mention from 1 person at least that had to reenter their passwords for their airport connections - might be worth rechecking those.
  3. ewilson6 macrumors 6502

    Nov 30, 2006
    run network diagnostics then post back...

  4. zxin thread starter macrumors newbie

    Aug 6, 2009

    I can connect to fine.
    I re-entered the WPA2 Personal key and it still doesn't work.

    I had also ran the network diagonostics and restarted my modem and router, and it says "Network Diagnostics cannot fix the current networking problems."

    This only happened after I updated, it was fine before I updated.
    I don't know why this is happening :(
  5. Bill Gates macrumors 68020

    Bill Gates

    Jun 21, 2006
    Can you ping the IP address of google? If that works, try entering your router's IP address as the DNS server in System Preferences.
  6. zxin thread starter macrumors newbie

    Aug 6, 2009

    Nope, I get "ping: cannot resolve Unknown host"
  7. iJiten macrumors member

    Sep 29, 2007
    Are you on Wi-Fi with the laptop unplugged? If your laptop is unplugged, plug the power cord back in. My MBP only works with Wi-Fi when the power cord is plugged in after the 10.5.8 update.
  8. Bill Gates macrumors 68020

    Bill Gates

    Jun 21, 2006
    THe IP address, not the name. I.e., "ping -c4"
  9. zxin thread starter macrumors newbie

    Aug 6, 2009
    I tried it plugged in, and unplugged. It doesn't work for either.

    I did that and got 4 packets transmitted, 0 packets received, 100% packet loss.

    It seems I am not the only one having this problem..
  10. ewilson6 macrumors 6502

    Nov 30, 2006
    wheres your picture of the network diagnostics?

  11. Enigmah macrumors member


    Jul 9, 2008
    Why the hell is this happening !!!!!
  12. vpdh6 macrumors newbie

    Aug 9, 2009
    Yeah, seriously. It appears to happen with only certain networks since I was able to connect to my friend's wifi (unplugged) without any problems.
  13. JDR macrumors regular

    Jan 26, 2008
    Chicago, IL
    I haven't posted here in a while, but we got a new wireless router yesterday, and for some reason my MBP with 10.5.8 wouldn't connect to the internet via wireless, though every single other computer did. I went crazy---called my internet provider, the manufacturer of the router, tried to change all these network settings...and I eventually gave up. I even went to my friend's house, where I've used the wi-fi before, and it worked fine (computer was unplugged :confused:).

    Then, out of the blue it seemed, the internet worked. I had plugged it in after giving up, and when I went to check later if it was working, BAM! It was. I got up to leave, and then I was back at square one. Plugged it back in, and the webpage loaded right up. Did some googling, which landed me here.

    Like the person below me said, what would cause this to happen only with my home network, and not my friend's, which works fine on my computer, unplugged and on 10.5.8?

    /end saga.
  14. wywern209 macrumors 65832


    Sep 7, 2008
    do you rly want to know?
    i would try to restart the computer. just to get things in order if the installs messed up something.
  15. NewMacbookPlz macrumors 68040


    Sep 28, 2008
    Run your software update, look to see if the Airport Client Update is available yet. It's for people who have upgraded to 10.5.8 and are having Airport issues.

    It just got launched for a bunch of MB and MBP models:

    MacBook (13-inch, Late 2007)
    MacBook (13-inch, Early 2008)
    MacBook (13-inch, Late 2008)

    MacBook Pro (15-inch, Early 2008)

    MacBook Pro (17-inch, Early 2008)
    MacBook Pro (17-inch, Late 2008)
  16. JDR macrumors regular

    Jan 26, 2008
    Chicago, IL
    NewMacbookPlz: Perfect, thanks for the heads-up.
  17. Stevo359 macrumors newbie

    Oct 22, 2009
    I just turned on my macbook after being off for a while, and I can not connect to the

  18. johngalt1945 macrumors newbie

    Mar 3, 2011
    SOLUTION: Macbook connects to router, but not internet

    This issue has driven me absolutely crazy, but here's the solution that worked for me...I hope it works for you.

    Issue # 1: Macbook Pro would not connect to Netgear router. By changing the TCP/IP settings in the Network Preferences window to Manual, I was able to connect to the router, BUT still not able to access the internet.

    Configure IPv4: Manually
    Iv4 Address: 192.168.1.x (for your router it will be different if Linksys, Netgear, etc.)
    Subnet Mask:
    Router: (again, this will be different depending on the router).

    HOWEVER, the above is meaningless, because while it connects to the router, it will not ALWAYS provide internet access.


    1. Turn off Airport

    2. Leave the "Configure IPv4:" set to Using DHCP - this should be the default.

    3. On the AirPort tab in Network settings, UNCHECK " "Remember networks this computer has joined"

    4. Highlight your router in the Preferred Networks: list, and remove it (click the "-" sign under the list

    5. Apply settings

    6. turn on AirPort, Add your router if not already there, and that should do it.

    The above steps should not need to be repeated each time. Once should do it, but if not, at least it's better than restarting the router each time, which essentially has the same effect as the steps above.

    Apparently, there's a software bug whereby if the Macbook finds an available IP address on the Router, it remembers that address. That's fine except that if another device "steals" that address when the Macbook is subsequently not connected, and the "Remember networks this computer has joined" is checked, it's not smart enough to find another available IP address. Instead, it assigns some invalid address beginning with "169.".

    By leaving the "Remember networks this computer has joined" UNCHECKED, it will look for a valid available IP address on the router each time.

    Good luck!!
  19. Ccrew macrumors 68020

    Feb 28, 2011
    Actually the name is a diagnostic. Can't see a name server so he's got a bad gateway in the network config - less doubtful since he's DHCP, or he has no entries in the nameserver tab.
  20. remoteONE macrumors newbie

    Aug 19, 2010
    That worked.

    Thanks , Johngalt1945.
    That procedure fixed it, I have been stuffing with this for 3 HOURS !

    I did try using DHCP but IPv4 just would not get the IP address that are set in the router.
    I have a router, with a transparent bridge, to another router that is ADSL connected.
    I could browse to all the Routers and APs, Skype worked , but could not load any web pages!

    Is there a OSX update to fix this bug?
  21. Gretschmann macrumors newbie

    Aug 4, 2010
    Hello all,

    I did what Johngalt1945 recommended but i still can`t log to the internet.
    I set IPv4 to manual and was able to get a airport signal but I still have a ! in my airport signal on the menu bar. I really don`t know what to do.

    I have a 2007 macbook and I have the 10.6.6 version.

    I also have the same situation as other member here on this thread, I can log to the internet when I am at work, no problem but not at home.

    I hope somebody can help me.


Share This Page