macbook runs perfect on battery-not on power charger!

Discussion in 'MacBook' started by tsiguy561, May 27, 2011.

  1. tsiguy561, May 27, 2011
    Last edited: May 27, 2011

    tsiguy561 macrumors newbie

    Joined:
    May 26, 2011
    #1
    hi, ive got a macbook here that runs perfectly on a battery, but it wont run on the power adapter. the magsafe turns green when plugged in, but it does not charge the battery or power the computer. any suggestions? thanks all

    ive replaced the DC in area where the charger plugs in with a working one, nothing. also tried the battery connector with no help there. so something else is wrong here, just dont know where to go next. if i plug the connector AND the battery in, the computer says its running off power adapter and not charging. if i then disconnect the battery and leave the cord plugged in, the computer shuts off so its not really running the computer, its just being read that it is.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Try resetting the SMC, instructions for which are in the following link under CHARGING.
    This should answer most, if not all, of your battery questions:
     
  3. tsiguy561 thread starter macrumors newbie

    Joined:
    May 26, 2011
    #3
    thanks, but i tried the PRAM, SMC, swapped out components for other components i had on hand and nothing. so now kinda looking to see what other potential causes of an AC adapter lighting up green and appearing just fine, but not charging the computer or battery.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    PRAM/NVRAM has nothing to do with power/charging/batteries, so that won't help. You might check out the link for troubleshooting MagSafe adapters, in the CHARGING section of the Battery FAQ. If your adapter and battery are fine, and you've properly reset the SMC, the culprit may be your logic board. Take it to Apple to have them check it out.
     
  5. tsiguy561 thread starter macrumors newbie

    Joined:
    May 26, 2011
    #5
    definitely not the battery or magsafe, im to the point of replacing internal components so i want to figure it out.

    guess im trying to figure out how it gets to the point of my magsafe turning bright green, but not doing anything beyond that. if theres an internal component that i can change that i have not already, or if it will just never work with power.
     

Share This Page