Macbook Unibody 2009 - Audio/External Monitor Problem

Discussion in 'MacBook' started by andrewlgm, Nov 12, 2011.

  1. andrewlgm macrumors 6502

    andrewlgm

    Joined:
    Feb 16, 2011
    Location:
    NYC
    #1
    Anytime I have my white macbook plugged to an external monitor, and I have my earphones on, I lose a slight amount of sound from the right earphone. Maybe it's been happening for a while, but since I only started using headphones with my macbook recently (working at night), I just noticed it now. This is really annoying. Does anybody know why? How can I fix this? Removing the minidisplay connector solves it, but then I have no external monitor.

    I've modified my macbook a few times since I got it in early 2010. So maybe I messed something up. It's the best computer I've ever had, and I don't want to upgrade to a newer one yet - I know it may sound weird, but I preferred the white macbook over everything else.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    What do you mean by "lose a slight amount of sound"? Have you checked the balance in the Sound preferences pane?
     
  3. andrewlgm thread starter macrumors 6502

    andrewlgm

    Joined:
    Feb 16, 2011
    Location:
    NYC
    #3
    the right earphone is lower in sound than the left. It's as if the volume on the left ear was on 8 and volume on the right ear was on 4. I've tried with over 6 pairs of headphones, and I like I said, the sound returns to normal when I unplug the external monitor. I've checked all settings. Solution so far was not use the macbook for sound when I have the monitor plugged in. iPhone does the job well, but it's pretty annoying that I can't use iTunes when using the external monitor. Anyway. thanks
     

Share This Page