Macbook unibody a1278 aluminum - not charging and reads 0% on any battery I put on it

Discussion in 'MacBook' started by asma123, May 3, 2011.

  1. asma123 macrumors newbie

    Joined:
    Apr 4, 2011
    #1
    so this macbook 2.0ghz unibody unfortunately suffered a minor beer spill. I opened it up and cleaned some minor corrosion on the logic board. Took out the keyboard and washed it to remove the stickiness. After everything is put back together, the computer would not charge or recognize the battery properly. I put in a working battery (I have the 2.4ghz model as well) and it does see I've put in a battery, but it would not run on the battery, and the charging percentage will remain at 0%. I've reset pram, smc. I swapped the battery cable and same thing. I can't see any burn marks so I need some help tackling this problem. I have no problem changing IC's as I have hardware repair experience, but I just need to know what to change. perhaps anyone have schematics?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    After a spill, all bets are off, as the extent of any damage isn't known. PRAM/NVRAM has nothing to do with battery/power/charging issues, so resetting that won't help. Resetting SMC can help in many situations. If the charger is working and the battery is good, the only component that's left is the logic board, which could have suffered damage from the spill.

    Instructions for resetting SMC and troubleshooting MagSafe adapters are in the CHARGING section of the following link. This should answer most, if not all, of your battery questions:
     
  3. asma123 thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #3
    after more testing and countless attempts are fixing the computer (even replacing IC's that seemed broken) had some times not having the computer turn on at all.... anyway I was able to spot a tiny little short on the board at the top of the board. jumpered it and voila! computer works again.
     
  4. asma123 thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    #4
    2008 MacBook Pro doesn't turn on but if I follow a procedure it does.

    so this 2008 macbook pro unibody (i believe this is the first model) with the removable battery doesn't usually turn on. however, I just found out that if I leave it out of power (unplug battery as well) and then put power back on, it will chime and seems like it will work it will have the folder with the ? on it. I haven't fully tested this yet since I have the hard drive ribbon unplugged at this moment.
    but when it does not power on, the fan will run and the led at the front will light up but just a blank screen. any ideas?

    I'll be doing a reflow on the motherboard tomorrow so we'll see how that goes it may help *fingers crossed* unless someone helps me out sometime in between that. thanks.
     

Share This Page