macOS High Sierra Update issues with the internal SSD

Discussion in 'macOS High Sierra (10.13)' started by mmrq01, Apr 8, 2018.

  1. mmrq01 macrumors newbie

    Joined:
    Apr 8, 2018
    #1
    Hello fellow community members,

    I need your help to resolve my issue. I have been searching for the past few days frantically and still not able to solve my issue. I sincerely hope that someone here can help me find a solution.

    I have a 2010 Imac 27 in with a built-in HD (1-TB). I had added an internal SSD (240GB) a few years back and kept the original HD as well. The computer has been running fine. I have been using my SSD as my primary boot drive and the HD still had the old OS software on it.

    Two days ago, I decided to upgrade the SSD software to macOS High Sierra. The installation took a very long time and I was able to get to the initial login screen and while I was trying to add my Apple ID the computer got stuck and I had to hard reset using the power button. The iMac only rebooted to the old software on HD and would not boot to SSD anymore. I have been reading that this may be due to SSD issue not being compatible with HS upgrade (APFS) volume but I am not 100% sure. Here is what I have done so far. I have an external Hard drive (4TB) that I created few partitions and on one of the partitions I installed a fresh copy of macOS HS (thinking that it will be APFS volume which would help me read my now APFS converted SSD but I still cannot read the data off of my SSD.

    when I boot to my fresh copy of SSD, and using the disk utility, I can see the iMac SSD-240 (disk2s1) however, it is greyed out and I cannot mount it. I clicked "Mount" many times but nothing happens. This is the SSD which is internal to the computer and have all my data that I need to access. [Unfortunately I have never created a time machine back up of my SSD]

    Not sure what else can I post here, but my ultimate goal is to get the data from the SSD (APFS) before I can format it and do a fresh install. If there is a way to fix the SSD to make it bootable again, I would love to try that. Please let me know if there is any other information I can provide to explain my issue.

    I am in dire need of the help and looking forward to the help from community on my issue.

    [​IMG]

    I have installed the macOS HS on the partition named "OS-HS" on my external USB hard drive

    [​IMG]

    iMac SSD-240 is the SSD that is internal and have the data to be recovered from.

    [​IMG]

    more information on the SSD.

    I have also tried the following command using terminal:

    Type This Into Terminal:

    diskutil list | grep --regexp=.*disk2.*

    This is what the commands returns. Still not seeing this in my finder's tab.

    [​IMG]

    This is what Disk utility shows after running the command. SSD still remains unmounted. clicking the "mount" does not do anything.

    [​IMG]
     
  2. Kingcr macrumors member

    Joined:
    Feb 1, 2018
    Location:
    UK
    #2
    When you say your computer wouldn't boot to the SSD anymore, do you mean that it doesn't show up if you hold down option while booting?

    Also, could you post the output of "diskutil ap list /dev/disk2"?
     
  3. mmrq01 thread starter macrumors newbie

    Joined:
    Apr 8, 2018
    #3
    OS-HSs-iMac:~ os-hs$ diskutil ap list /dev/disk2

    |

    +-- Container disk2 A7931AED-980A-483A-AF83-4CB76D2FDC81

    ====================================================

    APFS Container Reference: disk2

    Size (Capacity Ceiling): 239847653376 B (239.8 GB)

    Minimum Size: 144694349824 B (144.7 GB)

    Capacity In Use By Volumes: 140053639168 B (140.1 GB) (58.4% used)

    Capacity Not Allocated: 99794014208 B (99.8 GB) (41.6% free)

    |

    +-< Physical Store disk1s2 001C139A-15F9-4949-B0CC-FF1AAF3F2A6C

    | -----------------------------------------------------------

    | APFS Physical Store Disk: disk1s2

    | Size: 239847653376 B (239.8 GB)

    |

    +-> Volume disk2s1 4E96CCE9-907E-320F-924D-0508D8786378

    | ---------------------------------------------------

    | APFS Volume Disk (Role): disk2s1 (No specific role)

    | Name: iMac SSD-240 (Case-insensitive)

    | Mount Point: Not Mounted

    | Capacity Consumed: 138318475264 B (138.3 GB)

    | FileVault: No

    |

    +-> Volume disk2s2 68C6B8EF-C259-418B-9140-6F1177F08DFF

    | ---------------------------------------------------

    | APFS Volume Disk (Role): disk2s2 (Preboot)

    | Name: Preboot (Case-insensitive)

    | Mount Point: Not Mounted

    | Capacity Consumed: 20103168 B (20.1 MB)

    | FileVault: No

    |

    +-> Volume disk2s3 60A5BC90-F5E6-4F0C-B69B-ADB63378C327

    | ---------------------------------------------------

    | APFS Volume Disk (Role): disk2s3 (Recovery)

    | Name: Recovery (Case-insensitive)

    | Mount Point: Not Mounted

    | Capacity Consumed: 503939072 B (503.9 MB)

    | FileVault: No

    |

    +-> Volume disk2s4 3B951019-08B2-4E96-8156-4B23A0CE5282

    ---------------------------------------------------

    APFS Volume Disk (Role): disk2s4 (VM)

    Name: VM (Case-insensitive)

    Mount Point: Not Mounted

    Capacity Consumed: 1073762304 B (1.1 GB)

    FileVault: No
    --- Post Merged, Apr 9, 2018 ---
    I am currently doing a back up using the Carbon Copy Cloner. I was able to see the files. Once the backup is compelted, I ' I'll restart and try the hold "options" and see if I see the SSD in the boot options... will post back the results as soon as I am done with the back up of my files...
     
  4. lemonkid macrumors member

    Joined:
    Dec 23, 2015
    #4
    If you start up from your 'old' macos, the computer can't handle APFS. Disc utility can't see it. So you should indeed try to start-up from the SSD with the latest (10.13.4) on it.
    However you can't select it from system preferences as a start-up disc so you need to choose it while starting up. (with option)
    You should then keep in mind that it may take a considerable amount of time for you computer to start-up, and it would not hurt to wait a while when you try to log into your computer. All kind of processes will be working in the background. These can disrupt other processes. But they may be gone after you wait. Let your computer work while in log in position be if possible and not going into sleep mode a night. This may resolve things.
    I would do this first before going through new installations and deleting things.
     
  5. MIKX macrumors 6502a

    MIKX

    Joined:
    Dec 16, 2004
    Location:
    Japan
    #5
    Just for the hell of it. . try doing a PRAM reset TWICE = wait until you hear the "Happy Mac" chime TWICE !

    Hope it works out OK for you.
     
  6. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    OP:
    Without a backup of the SSD, you may have a difficult (if not impossible) task "getting your data back".

    Trying to understand your original post.
    IF you began a High Sierra install, and IF the SSD got converted to APFS (even if the install failed), the only way you're going to be able to access it (if you can access it at all) is with a version of the OS that supports APFS.

    Of course, that is High Sierra.

    You wrote:
    "I have an external Hard drive (4TB) that I created few partitions and on one of the partitions I installed a fresh copy of macOS HS (thinking that it will be APFS volume which would help me read my now APFS converted SSD but I still cannot read the data off of my SSD."

    Are you telling us that you have an EXTERNAL drive that is bootable to High Sierra?
    And when you boot from it, you STILL CANNOT MOUNT the SSD, either in the finder or using Disk Utility?

    If that's the case, there probably isn't much hope of recovering anything on the SSD.
    You could -try- something like "Disk Warrior", but I doubt it will do much for you (I could be wrong).
    You could try data recovery software (such as DataRescue), but again, not sure how much help it will provide.

    I really think the only way to recover the SSD will be to ERASE IT and "start over".

    "Them's the breaks" when one doesn't keep a backup. Stuff just disappears, and it's gone.

    A recommendation for when you reinstall:
    Create a bootable USB flashdrive installer and boot (and install) from that.
    You can use an 8gb or 16gb USB flashdrive and the free "Boot Buddy" to create the installer:
    https://sqwarq.com/boot-buddy/

    My final recommendation:
    I'd suggest you DO NOT reinstall High Sierra.
    Use "Low Sierra" (10.12) instead.
    Fewer problems!
     
  7. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #7
    The screenshot in the initial post shows that "iMac SSD240" is not writeable. That's likely why it won't mount. That could mean that the SSD has gone into read-only mode because it has detected a hardware fault. If you can check the other volumes on the SSD and they all say "Writeable" is set to no, then that's more likely the case. If nobody comes up with a viable answer for you by the time you're done with the CCC backup, I would call Apple to see if they can help. APFS is pretty new and in doing a search I don't see any results on a web search on this topic (system volume going read-only) -or- maybe the information on the drive and what it means is different for APFS vs. HFS+. In any case, the Apple help folks may have a simple solution for this - hope that's the case.

    If indeed the SSD has gone into write-only mode, you can try and search or contact the manufacturer for a possible fix. But typically, it means the SSD can only be used to recover your data and that's it.
     
  8. UncleSchnitty macrumors 6502a

    UncleSchnitty

    Joined:
    Oct 26, 2007
    #8
    Have you tried making a bootable USB High Sierra and choose install to the ssd? This doesn't format the drive it just writes the os on op. It looks like your data is still on there based on the drive space screen shot. so I wouldn't go nuclear and format just yet.

    One thing that bothers me is you have an external drive thats marked for backups but you didn't use it before an OS upgrade! Hang your head in shame sir! (just kidding this stuff happens)
     
  9. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #9
    You might find if you select Show All Devices, it will make management of your drives a bit easier. This puts you back in the "old" view.
     

    Attached Files:

Share This Page