Magsafe -connector, 2 of 5 pins have been pushed in

Discussion in 'MacBook' started by Zotaccian, Jan 28, 2014.

  1. Zotaccian macrumors 6502a

    Zotaccian

    Joined:
    Apr 25, 2012
    #1
    So, Magsafe stopped charging. The charger was given to me, I looked it and it seems like 2 of 5 connector pins in the Magsafe -tip have been pushed inside the connector head.

    Is it wise to even try to repair them, somehow pull them up etc? It is the L -shaped connector. If it is possible to fix it, is there good instructions somewhere how to proceed?
     
  2. Twimfy macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #2
    Buy a replacement. Never **** about with anything power related, it's not worth the potential risk.
     
  3. Zotaccian thread starter macrumors 6502a

    Zotaccian

    Joined:
    Apr 25, 2012
    #3
    Well, I migh end up replacing the entire cord since I already have another charger..... the charger which has the broken connector most likely still has working charging electronics since a silent hiss (very very silent) is heard when you plug it on power outlet.... but let's see...

    How common is this, how much force you need to actually push the pins inside? Never seen this kind thing. I favor the old T -model connector, but that's just because it does not block any USB etc. ports no matter how I install it.
     
  4. Zotaccian thread starter macrumors 6502a

    Zotaccian

    Joined:
    Apr 25, 2012
    #4
    Okay, I found thread which lead to these forums and also there was article at Apple.com about this so this is not the only case of this happening. I could pull one pin up but it seems that the another one is really damaged and not stuck.
     
  5. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #5
    Try a strong door magnet with no power going through it.
     
  6. Zotaccian thread starter macrumors 6502a

    Zotaccian

    Joined:
    Apr 25, 2012
    #6
    I tried a strong magnet but no luck. I ended up taking the cord from another charger and swapping it. Charger works now so now I have one fully working one and one totally useless.
     

Share This Page