Mail App is So Buggy!

Discussion in 'iOS 11' started by adham7897, Jul 28, 2017.

  1. adham7897, Jul 28, 2017
    Last edited: Jul 30, 2017

    adham7897 macrumors regular

    Joined:
    Jan 27, 2017
    #1
    The Mail app freezes immediately when opened. It will crash after 2 minutes.
    The only “fix” I found is to reboot the iPhone. It’ll work fot ~1 hour after rebooting.
    Everytime I want to check Mail, I need to reboot my iPhone.
    I’m on DB 4, but it’s been happening since beta 1. (iPhone 6)
    Anyone else experiencing this? Anyone can help?
    *Other than that, DB4 is perfect for me.*
     
  2. ck2875 macrumors 6502a

    ck2875

    Joined:
    Mar 25, 2009
    Location:
    Brighton
    #2
    Have you tried removing and then re-adding the mail accounts? Could be a corrupt mail database, etc.
     
  3. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #3
    Did that AND reinstalled the Mail app, worked for just half a day.
    Got other suggestions?
     
  4. stulaw11 Suspended

    Joined:
    Jan 25, 2012
    #4
    Not seeing this at all nor has it been reported. May want to try backing up and a clean install from the ispw.
     
  5. charlituna macrumors G3

    charlituna

    Joined:
    Jun 11, 2008
    Location:
    Los Angeles, CA
    #5
    Revert back to iOS 10.

    This is beta software. Things will be buggy. Sometimes until the last beta version if its not something that crashes the whole system or needs to be working for developers to test their apps.
    If you can't handle that then you shouldn't be using the betas. Especially as what sounds like your main device. Even Apple warns this when you go to download the software.
     
  6. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #6
    Betas are buggy?![​IMG]
    Trolls that reply “betas are expected to be buggy”, etc. on every post of someone reporting a bug.
    I asked if someone experienced that or if someone can help/has info on this. No need to troll like this on every other post.
    --- Post Merged, Jul 30, 2017 ---
    Tired of seeing that response on every bug post I made. Even saw some other users who write they know betas may be buggy just so they don’t get these responses.
     
  7. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #7
    This thing bugs me a lot so I have submitted a feedback report.
     
  8. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #8
    The weirdest thing is happening to me on PB3. Usually if iOS can't figure out my work exchange server it will give me an option to manually configure it. PB3 won't give me the option.
     
  9. ryxn macrumors regular

    ryxn

    Joined:
    Jun 5, 2017
    #9
    Suggestion to sticky this (only sort of kidding).

    This is a forum dedicated to the beta, I'm pretty sure users who post here already know things will be buggy. That's why they come here to discuss the bugs and possible solutions.

    I had problems with Mail in DB 1, but since then it's been relatively smooth. Do you have another iOS device you can test with?
     
  10. martint235 macrumors regular

    martint235

    Joined:
    Apr 13, 2016
    #10
    I agree. I think we all know the beta will have some issues.

    The OP's issue seems very strange though. I had no issues with the mail app on PB2 or PB3 so it seems unique to them. It may be worth going back to 10 and then trying a new install of 11.
     
  11. cableguy84 macrumors 6502a

    cableguy84

    Joined:
    Sep 7, 2015
    Location:
    Essex
  12. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #12
    No I don’t have.
     
  13. ryxn macrumors regular

    ryxn

    Joined:
    Jun 5, 2017
    #13
    Hmm. The first thing that comes to mind is that it could be some kind of issue where it's grabbing mail from an account, and some kind of problem with that is causing it to crash. So like was said before, my first guess is a corrupt mail database.

    I've never heard of this issue happening to others though. Worst case scenario is a backup or factory reset.
     
  14. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #14
    This happened to you?
    Please explain the issue?
     
  15. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #15
    My mail app randomly freezes. Restart could bring it back to work temporarily.
    I don’t know the reason why this happens. I also did not try deleting accounts since in beta3 it was not that buggy.
     
  16. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #16
    Same thing for me. Except that I need to reboot if iPhone’s been up for more than ~1 hour, or it won’t open at all.
    --- Post Merged, Jul 31, 2017 ---
    It’ll freeze and lag IF it opens, but at least it’ll work.
     
  17. DJLAXL macrumors 6502

    DJLAXL

    Joined:
    Jun 3, 2014
    Location:
    UT
    #17
    The problem with this is that, there is really nothing anyone can do besides reporting the issue. Workarounds are pointless because it will obviously be fixed in two weeks. If it means that much to you, then of course reverting back to 10 is the best thing you can do. I think the whole "this is broken at this point in time" shouldn't warrant an entire thread. A simple post in the beta discussion thread would suffice. It is beta software, and complaining that something isn't working is the same as telling someone that everything shouldn't be expected to work. You'd be surprised how many people don't get the "beta" thing and act as if its the final release (not saying this about YOU, but many others in general on these forums).
     
  18. adham7897 thread starter macrumors regular

    Joined:
    Jan 27, 2017
    #18
    Correct, but I didn’t complain, just tried to see if anyone can help with this bug I’ve been experiencing since DB1.
     
  19. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #19
    A bit cranky, are we?

    MRF is generally populated by two groups of folks: tech enthusiasts with greater than average knowledge of such issues or newbies with less than average knowledge and technological problems.

    Perhaps dispel with the sarcastic GIFs and name-calling with those trying to help? Perhaps preface your posts with “I know betas are buggy”?

    Just my .02. Best of luck.
     
  20. stulaw11 Suspended

    Joined:
    Jan 25, 2012
    #20
    The problem is NO ONE can help with crashes/freezes on a beta. No one knows what is causing it, if they are even experiencing it too (I am not for instance) and betas run a bit differently on different devices; and there is other stuff running like logging etc on betas.

    There is nothing anyone can do other than don't run beta software and get the guaranteed experience from an official release and wait until September.

    Deleting the mail app (wiggle mode and hitting x) is deleting nothing; it's been proven since iOS10 it just removes the icon from the homescreen. As already suggested try doing a backup and restoring the phone. That is the only way to "redo" the app data on the device. That is the only real answer anyone can give on a beta.
     

Share This Page