Mail App not working on Exchange: "The Exchange Server "null" is not responding."

jjohnson985

macrumors newbie
Oct 20, 2014
7
0
Thanks. Yes, I saw that post originally, however it doesn't match what shows up when I actually go through the steps. For example, there is not a continue button....

I didn't post steps. I referred to the steps in this post
http://forums.macrumors.com/showthread.php?p=19723960#post19723960

The ones I was quoting I noted do not work. The ones in the link above do work. If there is something you are unable to find in the steps from the link above let me know. I'm not sure which steps you are referring to that do not match.
 

derspook

macrumors newbie
Oct 27, 2014
4
0
There's an easier workaround than what some have been doing it seems.

I messed with the original solution and it did not work for me.

I am using Office 365 at work.

First step you enter in your Name Email and Password. It should have two buttons on the bottom, GO BACK and CONTINUE.

Click GO BACK

Enter in the correct credentials.
For me I needed to do \user.name@workemail.com

Enter the correct server name which for me was outlook.office365.com

Everything was fine and dandy after clicking continue to the end.
 

egragert

macrumors newbie
Dec 10, 2014
2
0
None of these work arounds are working for me

Hello, I too receive the infamous "server may be unavailable" message when trying to add a 365.com account in Apple Mail. I've tried the option key solution. I've tried deleting the "exchange" related items in the key chain. I've tried the fake domain address.

Still no luck. Any other solution suggestions?

Ed
 

derspook

macrumors newbie
Oct 27, 2014
4
0
Hello, I too receive the infamous "server may be unavailable" message when trying to add a 365.com account in Apple Mail. I've tried the option key solution. I've tried deleting the "exchange" related items in the key chain. I've tried the fake domain address.

Still no luck. Any other solution suggestions?

Ed
Did you try my above solution? I did not need to use a fake domain address.
 

egragert

macrumors newbie
Dec 10, 2014
2
0
Did you try my above solution? I did not need to use a fake domain address.
Hi derspook,

I tried your solution and it created the mail account. Thanks. But, it's not allowing me to send out and not receiving anything from 365. I'll look deeper at account settings.

Ed
 

derspook

macrumors newbie
Oct 27, 2014
4
0
Hi derspook,

I tried your solution and it created the mail account. Thanks. But, it's not allowing me to send out and not receiving anything from 365. I'll look deeper at account settings.

Ed
:) Glad to help a bit at least. I've had issues in the last few days with send/receive on O365. May or may not be related, but fyi.
 

greghageman1974

macrumors newbie
May 21, 2016
1
0
I figured it out!

To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
Yeah. That did not work