Mail keeps asking password when I try to send email. I'm sure of all settings, but...

Discussion in 'Mac Apps and Mac App Store' started by macmania82, Jul 22, 2009.

  1. macmania82 macrumors regular

    Joined:
    Apr 14, 2009
    #1
    Mail is making me mad :mad:

    I'm sure about all settings like SMTP, and other details are right. There is no problem to get email, but when I try to send it keeps asking password! and not sending!

    Can it be something about security settings or anything else? I'm pretty new at mac, I dont know many details.

    I appreciate all your helps! thanks!

    here is the panel which im asked for password all the time;
    [​IMG]
     
  2. walgman macrumors newbie

    Joined:
    Sep 12, 2008
    #2
    Apparently it is because you have set Mail to "check for new mail" too frequently. Some servers do not like this. Under preferences - general set mail to "check for new mail" less frequently.
     
  3. RumMunkey macrumors 6502a

    RumMunkey

    Joined:
    Nov 3, 2006
    Location:
    Canada
    #3
    Wirelessly posted (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17)

    Might be a corrupt keychain problem.

    I had this once, and it was complicated (and possibly caused?) by the fact that I was sync ing keychain to Mobile Me (.Mac then).

    I don't recall the exact fix, but do a Google search for "OSX Mail Keychain corrupt".
     
  4. freesonwang macrumors member

    Joined:
    Apr 19, 2009
    #4
    I sometimes get that when I am not online (the Wi-Fi is still "darkened/active" but the connection is really not there). Have you tried resetting your Wi-Fi? (Turn if off, and then on again?)
     
  5. MacVixen macrumors 6502

    Joined:
    Jan 26, 2009
    Location:
    Santa Cruz, CA
    #5
    Just to throw yet another possible solution out there :p

    I had this problem a couple of weeks ago. It turns out that I didn't have the password for my email server saved. I'm not in front of my MBP right now, so I can't give you the step-by-step sequences, but as I recall, I went into preferences where it shows you your email accounts. At the bottom there was a little drop down box where you could edit your server lists. From there I recall clicking "advaced" and that's where I could see that I didn't have a password entered. as soon as I entered the password and saved it, everything was working fine again.

    Good luck!:)
     
  6. macmania82 thread starter macrumors regular

    Joined:
    Apr 14, 2009
    #6
    wow! thanks for posts! I tried all you wrote, again and again. but no success :(

    Later I installed PostBox ( http://postbox-inc.com/ ) and everything is working great!!
     
  7. AllenKenya macrumors newbie

    Joined:
    Jan 17, 2010
    #7
    I experience this from time to time. I have no proof, but this is what I've deduced about the cause of this:

    1. I'm trying to access an SMTP server that has an enforced password change protocol and my password has expired.

    2. My internet connection has failed or is too slow (living in Africa, this is a real problem but it happened in the US, too).

    3. The SMTP server is temporarily down

    4. Thought I've not heard of an SMTP server that does this, it sometimes seems like a challenge -- i.e., the server asking me, "Are you really who you say you are?"

    Most of the time if it's not #1, reentering the password works. If not, I hit Cancel to skip sending for now. When I try later, it usually works.
     

Share This Page