Mail keeps popping up in the background

dsaponaro

macrumors newbie
Jul 18, 2002
22
0
Does anyone have any further insight into this issue? It's a problem that has been persistent through several major OS upgrades and insanely distracting while working. Currently running Catalina 10.15.2 and have yet to find a solution.
 

wordsworth

macrumors regular
Apr 7, 2011
166
49
UK
No insights, I'm afraid, other than, as with others' experiences, my Apple Mail began to periodically appear on my desktop unprompted by me. This problem coincided with my having just added a Gmail account. I subsequently searched online regarding the problem and eventually followed some instructions (via user questions/feedback on Apple's site, if I recall correctly) regarding Google account settings (amending these) but to no avail. I do think it's a Google thing – Google 'just checking in'. Not impressed.

I'm using Mojave on a 2015 MacBook Air.

Edit: I just remembered I'd copied this to assist me (when I did my online search about the Mail problem as mentioned above):

Begins:

Problem


The problem seems to be with Google Calendar Notification Settings. I had configured Gmail and my Google Calendar on the the Mac calendar app was disabled and yet I faced this issue


Solution:


Login into https://calendar.google.com > Settings > Calendar link > Notifications. Edit Notifications then unselect email from the drop down. Save it and then quit and re-open mail app.


Credit must go to the original poster for posting the solution, link is below:


Refer: https://discussions.apple.com/thread/7271461

Ends

Maybe it'll work for you?
 
Last edited:

dsaponaro

macrumors newbie
Jul 18, 2002
22
0
No insights, I'm afraid, other than, as with others' experiences, my Apple Mail began to periodically appear on my desktop unprompted by me. This problem coincided with my having just added a Gmail account. I subsequently searched online regarding the problem and eventually followed some instructions (via user questions/feedback on Apple's site, if I recall correctly) regarding Google account settings (amending these) but to no avail. I do think it's a Google thing – Google 'just checking in'. Not impressed.

I'm using Mojave on a 2015 MacBook Air.

Edit: I just remembered I'd copied this to assist me (when I did my online search about the Mail problem as mentioned above):

Begins:

Problem


The problem seems to be with Google Calendar Notification Settings. I had configured Gmail and my Google Calendar on the the Mac calendar app was disabled and yet I faced this issue


Solution:


Login into https://calendar.google.com > Settings > Calendar link > Notifications. Edit Notifications then unselect email from the drop down. Save it and then quit and re-open mail app.


Credit must go to the original poster for posting the solution, link is below:


Refer: https://discussions.apple.com/thread/7271461

Ends

Maybe it'll work for you?
Thanks for this... I hadn't heard of it before. I will give it a try and report back.

Not sure how it will fair though being as I don't use Google Calendars at all. I only have "Mail" active for my Google Account in System Preference's "Internet Accounts"