Massive OS X Problems

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Mike Teezie, Oct 6, 2004.

  1. Mike Teezie macrumors 68020

    Mike Teezie

    Nov 20, 2002
    A friend of mine has a 15" AlBook that he has had for about theree months.

    The OS is doing the strangest things. If you try to run Safari, the square pops us under the icon, but nothing happens. No beach ball, nothing. It just sits there, and you have to force quit it to make the traingle go away. This is how 90% of the programs are acting.

    So I downloaded the 10.3.5 update from Apple, and put it on my iPod. I got the Updater onto the desktop of the Powerbook. I tried to run the installer, but the installer program didnt load all the way. The window is open, and the buttons are there, but there is no text inside the buttons, and I'm getting the spinning beach ball. Only option is to force quit.

    I get the same thing when I try to run Disk Utility.

    I have NO idea what is going on, how this happened, any of that.

    has anyone heard of this, and any ideas on how I can fix it?
  2. kenkooler macrumors regular

    Jan 2, 2002
    Mexico City
    A friend of mine had this happen to him, he was using bad ram. As soon as he exchanged it, everything worked fine.
  3. jimsowden macrumors 68000


    Sep 6, 2003
    Ram, logic board, HD, or even corruption of the os. try repairing utilities.
  4. Mike Teezie thread starter macrumors 68020

    Mike Teezie

    Nov 20, 2002
    This is odd. The only programs that dont work are safari, disk utility, and and I can't get it to connect to the internet to check for updates.

    How could this have happened?

    All other programs run with no problems at all.
  5. Mike Teezie thread starter macrumors 68020

    Mike Teezie

    Nov 20, 2002
  6. Earendil macrumors 68000


    Oct 27, 2003
    If you aren't updating your OS, is it possible to run the "archive and install" from the CD? that may be the best thing...
    Never had to do it though, so I don't know.

    Also, for trouble shooting purposes, try starting up off the CD. If the problems happen under the CD it's probably one of the hardware problems listed above. If everything works fine, it's probably the OS, and you need to figure out your reinstall of choice.

  7. Counterfit macrumors G3


    Aug 20, 2003
    sitting on your shoulder
    Try booting from the install CD and repairing permissions.
  8. mr_mac macrumors member


    May 1, 2004
    Quebec, Canada
    May sound stupid, but does he use dual screen setup? If so, maybe your windows are in the other screen and OS X cannot get them back in the primary screen when it's not attached.

    I've had that problem several times. just trash the preferences.

    the 10.3.5 installer is probably not the one needed for his OS. Is this a full 10.3.5 update or just a 10.3.4 to 10.3.5 update?

    try downloading from his computer... always a good idea.

    Hope this helps,

  9. Macs R Us macrumors 6502

    Mar 8, 2004
    Here on My Mac(s) in my house in the USA!
    Well at least you did not have a Kernal Panic... FYI it happens with a computer that is upgraded to G3 and has 48mb ram w/ OS X, or at least qay to often for me:)....
  10. jap4n macrumors member

    Aug 10, 2003
    wellington, nz
    try deleting the .plist files in the library for the applications that dont run. Say, if Safari doesn't run, go to Finder, Search, "Safari" (local disks). there should be a couple of results. Make sure the application is closed. Delete the .plist file and empty trash. then try starting application again.

    otherwise, boot in single user mode (reboot, hold down "command+s"), wait until "user%" - then type "fsck -f". It may repair damaged parts on the disc. once finished, type "reboot".

    if it is a dual-screen prblm, should F9 expose the hidden windows? i've neverheard of a dualscreen prblm

    if problem persists, i'd have to say the unmentionable... reinstall :( (well, backup then reinst. :p)

    best of luck :)
  11. Mike Teezie thread starter macrumors 68020

    Mike Teezie

    Nov 20, 2002
    Thanks for all the help everybody. Nothing seems to be working - and get this - the computer won't boot from CD.

    I tried to boot it from the CD, and I get the strangest screen ever. It makes the chime sound, then the grey apple screen comes up, but the Apple logois distorted, and there is no and it goes nowhere from there.

    Any more ideas? A hail-mary before this thing goes back to Apple?

Share This Page