MBP 2010 running 10.6.7 suddently can't detect external monitor

Discussion in 'MacBook Pro' started by hajime, Jun 22, 2011.

  1. hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #1
    Hello. I have a HP 24" external monitor. It is connected to both the MBP 17" (2010) and a HP Desktop. The connection between the MBP and the monitor is the Moshi Mini-displayport to HDMI cable. I have been using the setup for about a month. There has been no problem. Usually, I just press a button on the monitor to switch between the two video sources.

    Suddenly, the monitor detects no signal even it is connected to both computers. I disconnected the HDMI cable between the MBP and the monitor. The monitor was able to detect the HP computer (connected via VGA). When I reconnected the cable again, the monitor cannot detect any computer. As for the Mac side, even I rebooted twice and tried to search for external display via the control panel, the system does not detect the monitor.

    I searched the net and it looks like some people have the same type of problem. Anybody knows how to fix it? Not sure if it has anything to do with 10.6.7. It worked at least from the date the update was released to today.

    Thanks.
     
  2. Nuckinfuts macrumors 6502

    Joined:
    Jun 15, 2011
    Location:
    Syracuse, NY
    #2
    Is the monitor detected in Bootcamp (if you have it installed)

    Have your tried (if you own) other mini displayport adapters?
     
  3. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #3
    That is a very good suggestion. Unfortunately, the monitor is not detected in Bootcamp. Everything was working before I left home. When I came back, it stops working. (Nobody else touched the system.) Hope it is not some kind of GPU issue like the 8600mGT.

    I do not have other mini displayport adapter.
     

Share This Page