Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MBP 2017 - Battery not charging

dotck

macrumors newbie
Original poster
Nov 13, 2019
15
9
Earlier this week I gave Big Sur Beta 10 a try and decided to install it on my MBP 2017 (13inch). Felt quite good so far.

Tonight I took the Macbook to watch some movies, but it won't react when typing any keys. It's obviously turned off. Pressing power button - nothing happens. Since it was on charger, I expect the battery to be fully charged, but obviously it isn't.

After reconnecting the charger and pressing the power button multiple times, the machine turned on and I was able to boot. The battery icon displays "Service battery" and "Battery Is Not Charging", even with the power adapter connected. Pulling it will power off the machine immediately. Tried SMC reset several times, without luck. According to coconutBattery I have 163 cycles and the battery is 3 years old. Is it normal to have a (entirely) dead battery after such period of time on a MBP?

Screenshot 2020-10-19 at 10.43.39.png
 
Last edited:

dotck

macrumors newbie
Original poster
Nov 13, 2019
15
9
While I made an appointment to get this fixed, I'm still curious if its really the battery (since it has 80% capacity left) or something else because it simply doesn't even try to charge the battery at all.
 

anpaman

macrumors regular
Feb 13, 2018
134
11
I also have MacBook Pro 2017 13 inch and the battery capacity also 80 % and still able to charge.

Before this the battery capacity is around 65 % but after I reinstall Mac OS it became 80 %.

You could try reinstall it to previously Mac OS.
 

dotck

macrumors newbie
Original poster
Nov 13, 2019
15
9
Reinstalling macOS did not help, which was expected. Genius Bar has diagnosed a dead battery and will send it in for repair.

Update: Got the machine back from repair. They replaced the battery, top case and display assembly. Feels like a new machine.
 
Last edited:

Eldiablojoe

macrumors 6502a
Dec 4, 2009
944
68
West Koast
My MBP won't charge regardless of which port I plug the adapter into. It was doing this quite a bit lately but intermittently. Now with the upgrade to Big Sur, it is completely not recognizing the power adaptor at all. Three years old and a dead batt? My last MB lasted 9 years before issues.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.