Resolved MBP always autocorrects from "i" to "I"

Discussion in 'macOS High Sierra (10.13)' started by MacUse-R, May 7, 2019.

  1. MacUse-R macrumors regular

    MacUse-R

    Joined:
    Dec 24, 2017
    #1
    So I don't know about the English language but in my language we don't usually write uppercase "I" in the middle of a sentence?
    My MacBook Pro on High Sierra always autocorrects when I write a lowercase "i" to an uppercase "I". If I want it to be a lower case "i" i need to go back and delete the "I" and write it again, and then the second time i write it it stays a lowercase "i"
    This is very annoying to me.
    I have tried going into keyboard settings and choose the "text" tab and then made a "short word" where i have chosen that when write "i" it should also show a lowercase "i", but that doesn't seem to work.
    And i don't see any other setting for changing this.

    So how can I change it so a lowercase "i" does not autocorrect to a uppercase "I"?
     
  2. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #2
    How do you refer you yourself in the first person? In English, the single letter “I” is only used to refer to oneself and is always capitalised as you would a person’s name.

    Just curious really, not sure how to help, what language is it?

    Is your main language an option in the System Preferences? If using a lower-case is a feature of the language it should be set that way if you’re able to change your system language to your native language.
     
  3. MacUse-R, May 8, 2019
    Last edited: May 8, 2019

    MacUse-R thread starter macrumors regular

    MacUse-R

    Joined:
    Dec 24, 2017
    #3
    Yeah maybe so, i´m not a native English speaker, but in my language the word "I" consist of three letters and we definitely don't write the first letter with a uppercase (not even for the word "I"), unless its the first word in a new sentence. And the word "I" in my language means something else (it actually means "inside" or "in").
    But sure the first letter in names are written with an uppercase in my language as well, but not for the word "I" (me).
    Thats why to me it looks a bit strange that all of a sudden in the middle of a sentence it throws in a uppercase letter.

    I think the MBP automatically recognises which language i´m writing in?

    But okay, so then I guess thats how it should be in the English language. Then I will not try to do anything about it since thats how its suppose to be. Thanks.
     
  4. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #4
    OK cool, yeah if you’re specifically looking to write in english, you always capitalise the first letter of someone’s name and if referring to yourself you capitalise the I regardless of its position in the sentence.
     
  5. MacUse-R thread starter macrumors regular

    MacUse-R

    Joined:
    Dec 24, 2017
    #5
    Good, then I know. Thanks.
     

Share This Page

4 May 7, 2019