MBP Retina 2012 A1398 not charging. Mag safe lights up but computer dies when the battery drops to 0

zerimas

macrumors newbie
Original poster
Mar 19, 2019
4
0
OK. So I obviously broke something mucking around with my 2012 MBP Retina A1398. It put a new battery in it and it was working, but then it suddenly stopped charging. A different MagSafe did not fix it. When I plug in the MagSafe it goes from green to amber. However the battery does not charge. If given a battery with charge in it the computer will boot and function. It shows the remaining battery percent but it continues to drain and says it is "not charging".

What did I break? Apple just scolded me for touching their precious computer without permission and told me nothing. I've been searching for days to no avail. It could be a charging circuit issue, but I can't even find instructions on how to diagnose that for my model.

The computer will not boot with a dead battery or no battery installed. I tried to follow the instructions to bypass the SMC but they did nothing. The adapter seems to be working and the computer recognizes when it is plugged in, but no current seems to be flowing to anything. How do I fix this or even attempt to diagnose it? All of the instructions I've seen have not included a scenario in which the MagSafe appears to function correctly, but it does not charge. It isn't the battery either because the working battery I took out doesn't function either.

Thanks
 

Webster's Mac

macrumors regular
Dec 18, 2016
241
188
OK. So I obviously broke something mucking around with my 2012 MBP Retina A1398. It put a new battery in it and it was working, but then it suddenly stopped charging. A different MagSafe did not fix it. When I plug in the MagSafe it goes from green to amber. However the battery does not charge. If given a battery with charge in it the computer will boot and function. It shows the remaining battery percent but it continues to drain and says it is "not charging".

What did I break? Apple just scolded me for touching their precious computer without permission and told me nothing. I've been searching for days to no avail. It could be a charging circuit issue, but I can't even find instructions on how to diagnose that for my model.

The computer will not boot with a dead battery or no battery installed. I tried to follow the instructions to bypass the SMC but they did nothing. The adapter seems to be working and the computer recognizes when it is plugged in, but no current seems to be flowing to anything. How do I fix this or even attempt to diagnose it? All of the instructions I've seen have not included a scenario in which the MagSafe appears to function correctly, but it does not charge. It isn't the battery either because the working battery I took out doesn't function either.

Thanks
Did you try reinstalling the old battery? Also, when you took out the connector for the old one, did you pry it with a metal tool (flathead screwdriver for example) or a plastic spudger?
 

zerimas

macrumors newbie
Original poster
Mar 19, 2019
4
0
Did you try reinstalling the old battery? Also, when you took out the connector for the old one, did you pry it with a metal tool (flathead screwdriver for example) or a plastic spudger?
I tried the old battery. The computer will draw power from it, but it will not charge it. I used a plastic spudger to pry up the connector.
 

zerimas

macrumors newbie
Original poster
Mar 19, 2019
4
0
I've tried every conceivable solution involving removing the battery and plugging it in to no avail.