MBp Retina w Radeon 2015 no brightness under Windows 10 and Bootcamp 6

Discussion in 'Windows, Linux & Others on the Mac' started by walvis, Feb 11, 2017.

  1. walvis macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    London, UK
    #1
    I have an up todate macOS Sierra rMBP with maxed out specs and the AMD Retina GPU from mid 2015 (last model before current Touchbar MBPs). Having installed Windows 10 Home using Bootcamp Utility today, initially all worked well until I used the Apple Update Tool in Windows to update to Bootcamp 6.0 (current version). This disabled the brightness setting, not only on the Keyboard (all other F buttons such as keyboard backlighting, volume etc still work) but also it removed the ability to adjust brightness from the Windows settings. I can tick and untick the automatic brightness adjustment in Windows 10, but this does not do anything. I also downloaded the Bootcamp AMD drivers from the AMD website, again no change. I am a bit lost and cannot imagine that there is no solution.... Any ideas?
     
  2. sunapple macrumors 65816

    sunapple

    Joined:
    Jul 16, 2013
    Location:
    The Netherlands
    #2
    Hi, I am having this same issue. It´s night, it´s dark, Windows is still being very very bright. Have you found a solution yet?

    An other problem is that the AMD software keeps bugging me with new updates, but if I try to install them it leads to Error 173 ´can´t install update because no AMD hardware was found. Manual installation doesn´t work either. System tells me it´s up-to-date.

    After this fails, the software disappears from the taskbar which isn't very helpful either.

    I have tried the same things as you, no result.

    Found somewhere on the Apple discussion forums that there is something called a Bootcamp repair utility, but I can't find that (installation was without having to download additional software to a disk).
     
  3. cipher240 macrumors newbie

    Joined:
    Sep 6, 2017
    #4
    i have the exact same problems (mbp mid 2015 r9 m370x) and am looking for a fix, there is no way to change the brightness in bootcamp win10, physically by keyboard or software right now.

    i have tried SMC & PRAM reset, reinstallation of BC 6 drivers, along with the individual keyboard driver AppleKeyboardInstaller64.exe.
     
  4. cipher240 macrumors newbie

    Joined:
    Sep 6, 2017
    #5

Share This Page