Resolved MBP stuck to the spinning wheel, won't boot after deleting something from "/System/Li

Discussion in 'MacBook Pro' started by MysteriousEnoch, Dec 28, 2011.

  1. MysteriousEnoch, Dec 28, 2011
    Last edited: Dec 29, 2011

    MysteriousEnoch macrumors newbie

    Joined:
    Dec 28, 2011
    #1
    Hi all,

    I have a MBP 13" (early 2011) running Lion 10.7.2 and some days before, I wanted to host an HTTP server on it. I googled and found I should turn on "Web Sharing" for this feature. But unfortunately, it just wouldn't start. I googled again and found a solution (I think). I tried deleting the disable key and
    <string>-D</string>
    <string>WEBSHARING_ON</string>

    from "/System/Library/LaunchDaemons/org.apache.httpd.plist". I couldn't save the file because it is protected. So I tried copying all the content of the file and save it to a new file with the same name, deleted the original file, and put the new one back to the directory. Nothing worked. I couldn't edit the new file as well. So I put the original file back and replaced the new one. Then I tried to change my rights of that directory as well as the file to "Read and Write". And I managed to edit the file! I deleted the mentioned sentences and saved it. Then I tried turning Web Sharing on for about a hundred times, but never succeeded. So I turned off my MBP and slept. OK, the next day when I decided to try again, I found the machine won't boot! It got stuck to the grey screen with Apple logo and a spinning wheel permanently. Every time I needed to hold the power button for 4 seconds to turn it off. I've tried SUM (command-S) and ran fsck, no problems were found. I also tried the method from http://support.apple.com/kb/TA20809 , but still couldn't get past that grey screen. Cannot boot into safe Boot also. I don't if it is a problem related to the alias of that file because I had deleted it and put it back. Please help. Many thanks.

    P.S. If can't solve it, should I bring it to Apple Store and ask for Genius?
     
  2. Aliascognito macrumors member

    Joined:
    Nov 5, 2010
    Location:
    Ireland
    #2
    A similiar thing happened to me when i deleted a .plist file for me, all i did was purge my machine.
    Cmd+Option+P+R

    That worked for me but theres no guarentee it will work for you...
     
  3. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #3
    I take it you can't boot into recovery neither then?

    turn off your machine, hold the cmd key, see the options for the boot up process-which drive to use. You should select recovery partition. Then it will load up, try n see what goes on in there?

    The long n short of it is, don't edit anything in the ~/system/library, or ~/library/--- i have learnt the hard way that doing so really messes stuff up unless you happen to have a degree in BSD, *nix, and Darwin etc ;) heh
     
  4. MysteriousEnoch thread starter macrumors newbie

    Joined:
    Dec 28, 2011
    #4
    Thanks for all your replies. Although resetting PRAM and NVRAM doesn't work for me, but booting into recovery mode and repairing permissions did work fine for me. Now all things go right and I don't think any of my settings is gone.

    Thanks a lot!!
     
  5. Steve.P.JobsFan macrumors 6502a

    Steve.P.JobsFan

    Joined:
    Jan 27, 2010
    Location:
    Cincinnati
    #5

    Your welcome! Be sure to edit your original post, and change the thread to resolved. :D
     
  6. MysteriousEnoch thread starter macrumors newbie

    Joined:
    Dec 28, 2011
    #6
    Sorry but how can I set it to resolved?:confused:
     

Share This Page