MBP to external monitor

Discussion in 'MacBook Pro' started by becassin, Jan 17, 2013.

  1. becassin macrumors newbie

    Jan 17, 2013

    Fairly simple problem, but I can't find out where is the issue.

    I got:
    - Macbook pro dual core 2 (mid 2010)
    - iiyama prolite pl2409hdsb-1 (24'',native resolution 1920x1080)
    - Dr Bott Mini DisplayPort to HDMI Cable 3,0m (see here )

    I thought I would be able to use the native resolution of the screen, but in OS preferencies, the max resolution I can reach is 1600x900 px, pretty horrible!

    Any thought?

  2. Interstella5555 macrumors 603


    Jun 30, 2008
    Try turning "mirroring" off, should allow you to use the max resolution on the external display.
  3. becassin thread starter macrumors newbie

    Jan 17, 2013
    Mirroring is off, I'm pretty sure of that as both screens don't display the same thing.

    I just tried with a recent macbook air, works super fine.
    So the problem seems to come from my mpb, but it says here, under "2nd Display Support" that the maximum supported resolution is 2560x1600.
    Is it again a question 2560x1600 not being a HD resolution?

    note: the format of the resolution name with the macbook air is "1080p" instead of "YYYxYYY", that's weird.

    note 2: I'm currently running OS 10.6.8, any chance a software update might solve the issue?
  4. seveej macrumors 6502a


    Dec 14, 2009
    Helsinki, Finland
    Does your machine recognize the display (maker, make)?

  5. becassin thread starter macrumors newbie

    Jan 17, 2013
    Ok, found the solution, more of a workaround:

    - In the display preferences, I ticked the "display monitor settings in top bar" box.
    - Via the top bar preferences, I extended the "number of recent elements" from 3 to 10.
    - Magically, the 1080p option, that wasn't in the preferences, appeared, so I just selected it and it works fine.

    note: works for both DVI and HDMI


    Yes it did recognize the display from the start (displaying the reference in the preference window title)

Share This Page