MBP wifi dropping (I have searched a lot with no solutions) plz help

Discussion in 'MacBook Pro' started by pdormian, Aug 16, 2008.

  1. pdormian macrumors newbie

    Joined:
    Aug 16, 2008
    #1
    Hello,

    I have a macbook pro and the wifi will simply drop after about 10 - 20 minutes of use. The wifi signal strength will continue to show 5 bars, but at this point the network is totally dead--I can't ping the router anymore.

    The internet itself is fine since my iphone can access the internet just dandy when my mac is chasing its own tail at light speed.

    Here is some system description stuff that might help,

    OS Version: OS X Leopard 10.5.4
    Darwin Kernel Version 9.4.0, xnu-1228.5.20~1/RELEASE_I386 (Obtained from issuing "uname -a" from Terminal [Applications/Utilities/Terminal])

    Model Name: MacBook Pro
    Model Identifier: MacBookPro3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 2 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MBP31.0070.B07


    Wireless Card Type: AirPort Extreme (0x168C, 0x87)
    Wireless Card Locale: USA
    Wireless Card Firmware Version: 1.4.3.1
    Current Wireless Network: XXXXXXX
    Wireless Channel: 1

    Wireless security is via WPA using 802.11G

    Here is some history that might help,

    1. About a week ago, I gave my apple in for repairs because the keyboard and trackpad were dead--they replaced those parts and I got the computer back.
    2. before this repair, I had no problems with my wifi dropping.

    And here is stuff I have already tried that have *NOT* solved my problem:

    1. System update (nothing to update)
    2. Changing the service order of the Airport Card (moved it to the top)
    3. Clearing the KeyChain to avoid password resolution problems
    4. Changing user account to a fresh one incase of stale/bad user defined configuration data
    5. Watching Console for many many hours reading the system log outputs... No kernel panics, nothing shady...
    6. Upgrading the firmware on my router to its latest version
    7. Checking the access control to my SSID's entry in the keychain, currently SystemUIServer, AirPort, System Preferences, and airportd have access.
    8. Cooled my computer to a block of solid ice to avoid "Heat problems and packet loss issues" which has been mentioned online in several places.
    9. Changed the Energy Performance settings to make sure there wasn't some kind of "sleep" issue with the airport card

    And here is some solutions that have crossed my mind that I am not keen on doing at the moment:

    1. tossing the macbook out the window
    2. burning down a genius bar--every time I go there, they tell me things I already know and get stuck way before I even got stuck. I just politely stand there and smile and pretend to be a dimwit and let them have their ego boost.
    3. .... jokes jokes... I have to stay light hearted you know, this is extremely frustrating :)

    Please for the love of god if anyone has a solution to this help. At this point I don't know if its hardware software, firmware or anything for that matter. I don't even know how I am going to convince the "geniuses" that its broken... they will just say "looks like its working" and send me home.

    My sneaking suspicion is they screwed something up while servicing my keyboard, but how do you really make a case for something thats intermittent? Are they simply going to say "oh we believe you, we'll swap out your airport and if that fails, then your whole system"?

    sorry for the long post.
     
  2. icebook2002 macrumors newbie

    Joined:
    Jul 3, 2006
    Location:
    UK
    #2
    Hi the following worked for me, i don't make any guarantees lol...

    On router change the channel (higher the better I have 13) bleed over from cordless phones etc can interfere;

    In network preferences set Configure IPv6 to off;

    When network drops just click on the airport icon and wait till it stops whizzing round;

    Every now and then, though I am sure this doesn't do anything but makes me feel good, I go into terminal and type dscacheutil -flushcache

    Other than that I am sure some bright spark on here has some ideas.
     
  3. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #3
    Thanks... I am sure its not a wireless signal problem because my iphone works just fine on the wifi network while I'm holding it right next to the mac.

    I have already disabled IPv6, and I keep doing the whole "holding the wifi icon and watching it whiz" it doesn't help.

    In my case I have to say "Turn Airport Off" then "Turn Airport On" and my wifi comes back.

    Thanks for your help anyway, its greatly appreciated.

    Oh and P.S. I mean to offense to any geniuses that work at the genius bars which might frequent this website--I completely understand that the service and system is setup to help the general public. I have worked in IT before and have sympathy for it...
     
  4. hitnrun7 Guest

    Joined:
    Jul 3, 2008
    #4
    This also happens to me occasionally, current 2.5GHz Penryn MBP.


    Any help would be appreciated, and i disabled IPv6 already.
     
  5. icebook2002 macrumors newbie

    Joined:
    Jul 3, 2006
    Location:
    UK
    #5
    The one other thing I didn't mention that I did, in network preferences I deleted all the stations (I hop round loads and there are some unencrypted ones around me also) listed and then re-added my original router back on.

    In my case I had it down to the fact that until I changed channel whenever my mbp 'lost' connection to the router it would scan and try to attach to any router available and ignore the preferences in my network settings... hence why I deleted the strays in there.

    There was an app, for the life of me can't remember its name, where you could actually see how many routers were using your frequency and how much noise was on that frequency... Wish I could remember the name - I just head for channel 13 now as it worked for me.


    Anyway hope you get some more help with this.
     
  6. winninganthem macrumors 6502a

    winninganthem

    Joined:
    Jun 10, 2008
    #6
  7. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #7
    More in store...

    Yes I reset the PRAM... didn't help anything.

    Took it to the genius bar today and got the usual genius response. "Sir you will have to be able to reproduce the bug for us to do anything about it" Obviously I couldn't reproduce the bug for him while standing there, I remember there was a law named after this... lol what was it? :D

    Well apple, why don't you tell me something: If you're not paying me 100k/year to debug your damn OS for you and its not open source how the hell do you expect me to do it? I mean seriously... A lot of driver level / OS level bugs are intermittent because of locking / ISR bugs--but I digress.

    I did a brand new boot of Leopard today, and its the same damn issue. Wiped my disk clean and I'm back to square one.

    Now however I have at least one reassurance: Apple F**CKED up and not me. God bless log files.

    Aug 17 23:21:17 XXXXXXXXX-macbook-pro SystemUIServer[82]: Error: airportd MIG failed = 1 ((os/kern) invalid address) (port = 63747)

    So we come back to the main point which was the case when Leopard first came out: It was a piece of **** then, and its a piece of **** now. They built an ivory skyscraper using toothpicks instead of steel.

    A computer manufactured in 2008 which does not have seamless working wireless is a BRICK. If the icons on my Mail application looked less snazzy I could live with it. When my wireless fails, apple must pay!! :mad::mad::mad::mad:

    End Rant.
     
  8. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #8
    Found a solution!!!

    Ok so here it goes, I kept fiddling with the thing and this seems to solve the issue.

    You must clear out the "preferred networks".

    Apple -> System Preferences.

    Click Network.

    Click Airport.

    Click Advanced...

    Then you see a list of your Preferred Networks.

    Clear out the list completely. Delete every entry by clicking the "-" square in the lower left hand corner.

    Then uncheck "Remember any network this computer has joined" (or make sure its not checked)

    The first time you connect to the network, it will ask you for your password. Enter your password, but uncheck the "remember this network" (or something like that), and store your password in the keychain.

    From this point on, whenever you want to use the internet, you have to select the AP (access point) manually, but the connection remains solid.

    Hope this helps someone else.

    Best Regards. :D
     
  9. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #9
    Ummm... *pluck* last strand of hair

    After about a good 4/5 hours of stability, the same thing happened again. Right after posting my last comment too... LOL (all I can do is laugh at this point)

    But I guess this is something that I would expect. I mean rationally thinking about it, if I clear out my preferred networks, if my Wifi signal gets dropped (which is something that happens every so often) the computer wouldn't automatically connect back to anything, and simply sit there sucking its thumb.

    But what still intrigues me is the fact that it shows five bars for the wifi connection strength even after the connection is dropped.

    I give up :-( time to buy a big reel of CAT5 cable.
     
  10. hitnrun7 Guest

    Joined:
    Jul 3, 2008
    #10
    Only CAT-5?

    I too have resorted to using the good old wire... so im tethered to my desk, although i dont have this dropped Wi-Fi problem that often, its just nice to have a steady connection.
     
  11. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #11
    I am having the same problem on both the MacBook Pro and Macbook. I tried using the WDS because i happened to have an Airport Express as an Access Point originally, and it helped.

    But I'm unable to get a good signal in the other room and before this last weekend, everything was working fine.

    The signals are still weak and my connection speeds are pretty horrible. I'm using the N settings and I'm only getting about 140kb/s. I think I can get faster speeds on my iPhone Edge network.

    I use iStumbler to track all the information. I've tried a few of the recommendations on here including clearing the PRAM, removing the preferred networks, changed channels, removed security, changed to N only, WDS. nothing has worked so far.

    At this point I'm about to go to the neighbors and knock on their doors to see if they installed a jammer.
     
  12. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #12
    lol... yea good ol' tested CAT-5 nothing fancy for me anymore. Maybe some coaxial cables instead of twisted pair :D

    I just bought a Linksys WRT54GL router which I plan on putting DD-WRT (open source router firmware) to make sure its not my router.

    My current router is a DLink WBR-1310. On the surface it seems ok but I suspect there is an evil that lurks in its belly!!! Aaaarrrr

    I can't really be tethered at the moment since the router is downstairs, and I sit upstairs--I'm not really at liberty to move things around, which sucks, otherwise I would have just chosen the wired connection a long time ago.

    Then I could still fool my friends into thinking my macbook is hella cool... "hey guys look at my cool macbook, I'm online with safari... (just don't look more than 10 minutes thats the crap-out threshold)" lol

    I'll keep you guys posted. :cool:
     
  13. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #13
    Today I did a hard reset (don't know why I haven't tried that yet - wait i remember because all my settings would be lost) and switched to N only (which I have tried) that seems to have helped a lot.

    Now I actually think someone is jamming my signal... rhasberry... It stays good in the other room. WDS does b/g so just did an extended network with the Airport Express in the living room.

    Yeah I spent last year telling my friends how awesome the Mac is and now this. Poop. Who uses Safari? I'm on either Camino or Firefox.
     
  14. MusicallySilent macrumors member

    Joined:
    May 23, 2007
    #14
    Im leaning almost towards blaming it on your router. My friend came to my house the other day, and we stood in my room and got about 8000 down and 1000 up on comcast to a speedtest server 50 miles away 2 floors way from my router (however we were directly above it and both the router room and my room have windows, however the router is on a shelf in a very thick oak desk and is behind a printer) I also read somewhere that having the antennas tilted at the same angle as the receiving antenna can help... the mbps is horizontal so tilt your router antennas horizontal too and that may help.

    Router Linksys WRT54GS (Speedbooster = S) first edition (blue box)

    For all you know your iPhone is perfectly content with your Dlink router, but your MBP doesn't play nice with it. Dlink DIR655 (N extreme) works well also, my friend has one of those, he also has an older belkin near his room and even 30 feet away his signal craps from that all the time.

    My router http://www.linksys.com/servlet/Sate...nksys/Common/VisitorWrapper&lid=4717633028B05
    I think it has slightly longer antennas too than the regular 54G
     
  15. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #15
    Update: I assumed switching to N had fixed the problem. But what I noticed that my MacBook Pro now has this issue where when I ping the router, I see it send and receive a couple of packets normally at 1-3ms then two packets come in at around 700ms and 1200ms then a the same 2-3 packets at 1-3ms and then two packets come in at around 700ms and 1200ms and it keep cycling like that.

    From the same spot in the house, my wife's Macbook gets steady ping times of <1-3ms. So I think it's the MacBook Pro. I'll have to pop over to starbucks or a friend's house and try it on their router to see if it's the airport card.

    But what happens eventually, and I don't know exactly how to reproduce this, the Time Capsule will stop accepting connections until I do an update to refresh it.
     
  16. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #16
    Another Update: Did more experimenting...

    I rolled back to 7.3.1. Didn't really help. But I did notice that the connection is fine until I close my Macbook Pro. Then when I open it and try to reconnect, the connection times out and everyone else (the macbook) is knocked off the network. I then have to go to Airport Utility and perform an update for the computer to be able to connect again.

    This is definitely an issue with the AEBS and the Macbooks. Whatever that issue is, I hope Apple is working on a fix, because it seems that a few people are having these issues.
     
  17. SimiM macrumors newbie

    Joined:
    Aug 17, 2008
    #17
    I'm having the same problem, the wi-fi comes and goes. Does anyone know if the macbook has this problem too?
     
  18. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #18
    So I tried more settings and I turned on the Client Access and added the laptops and also assigned the IP addresses. It seems to be holding ok for today. This was after I changed it to 7.3.1
     
  19. Bootsie macrumors 6502a

    Bootsie

    Joined:
    Jan 23, 2008
    Location:
    Utah
    #19
    Should I be worried?

    I am planning on buying a Macbook Pro when they are updated (although I might get the current version if they don't change much and I can find a great deal).

    But I am connected to a Wi-Fi network about 12+ hours a day, and I don't have the option of tethering. Is this problem something that I should take into account when buying? I just cannot deal with losing my connection like that, even OS-X isn't worth that much hassle.
     
  20. hitnrun7 Guest

    Joined:
    Jul 3, 2008
    #20
    Are all the people who are having this issue using D-Link routers?

    It may be a common link, im using the DIR-615, yet when im at a friends house i can connect flawlessly to either his WBR-xxxx or his DIR-655.

    Just me thinking...
     
  21. akchang macrumors newbie

    Joined:
    Aug 18, 2008
    #21
    This is the worst, but the connection is unstable again. I don't know what else to do at this point beside pray.
     
  22. Sharky II macrumors 6502a

    Sharky II

    Joined:
    Jan 6, 2004
    Location:
    United Kingdom
    #22
    Same issues here - on all networks really, not just home, and it's NOTHING TO DO WITH CHANGINC ROUTER CHANNELS!! :rolleyes:

    15" 2.16GHz Core Duo MBP

    Only advice i have is - don't set your laptop to sleep, the wireless seems to be much better on a clean start up...

    Also the wireless on my mac pro is pretty crap compared to the imac 2.8ghz 24" in the same studio which runs tiger :eek:
     
  23. pdormian thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #23
    D-Link sucks

    Ok, I started this thread, and I can put some things to rest right now.

    D-Link is to blame.

    Not my mac.

    Not OS X.

    Not Configuration Options.

    None of that.

    Just D-Link.

    I just bought a Linksys WRT54GL router and hooked it up. Everything works, no dropped connections. No BS.

    Its been stable for the entire day now.

    As someone already figured out, the running thread of issues is based around D-Link routers.

    I have solved all my connection problems with 54 dollars. I suggest that you guys do the same instead of go through all this frustration and anguish. I hate myself for not doing it earlier. :D
     
  24. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
  25. Sharky II macrumors 6502a

    Sharky II

    Joined:
    Jan 6, 2004
    Location:
    United Kingdom
    #25
    i run only apple hardware at home, this happens in places with netgear routers, d-link, etc etc
     

Share This Page