MBP won't stay asleep with ext monitor

Discussion in 'MacBook Pro' started by hehe299792458, Jun 22, 2011.

  1. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #1
    I have an external monitor (old LG model) connected to my 2011 MBP via mini Displayport to VGA connector. When I close the lid, the MBP goes to sleep, but after about 5-10 minutes and won't go back to sleep unless I open the lid and close it again. I've found my computer overheated almost after an entire night running with the lid closed. is there any way to make sure the computer stays asleep without disconnecting the external monitor? I used 10.6.7 with all updates applied.
     
  2. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #2
    With the external display, your notebook goes into Clamshell mode when you close the lid. It's a feature, not a problem.

    I don't know if there's a way to turn off the Clamshell mode, since I have no interest in turning it off. You might just have to get used to unplugging the display adapter before closing the lid.
     
  3. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #3
    Are there any other peripherals connected to the macbook, besides the display? If a mouse or keyboard is present, a slight jiggle of your desk probably wakes your computer from sleep and makes it enter clamshell mode.

    Also, your computer did not overheat as you say. If it had, it would've shut itself down to prevent damage to internal components, since you found it awake, it wasn't overheating.
     
  4. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #4
    I believe the mode you're referring to is outlined here: http://support.apple.com/kb/ht3131

    However, in that article, Apple says the computer would still go to sleep with an external monitor attached, but that if you want to use it in ClamShell mode, you have to wake up the computer again.

    I tried both - with peripherals and without peripherals. Neither worked. And without the external monitor attached, the computer sleeps fine with a mouse.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    That is very odd.
     
  6. hehe299792458 thread starter macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #6
    It is. I heard people were having difficulty keeping their Macs awake in Clamshell mode, not the other way around.
     
  7. scarboni21, Jun 23, 2011
    Last edited: Jun 23, 2011

    scarboni21 macrumors regular

    Joined:
    Jun 23, 2008
    #7
    There was another thread where the OP fixed the problem by turning off "wake on network activity" in settings.

    Edit: I cant find the exact thread but i found a link in another thread that will let you diagnose what is waking up your mac

    http://osxdaily.com/2010/07/17/why-mac-wakes-from-sleep/
     

Share This Page