Mesages showing up as from my email, not phone number..

Discussion in 'iOS 8' started by Meathead1, Oct 28, 2014.

  1. Meathead1 macrumors member

    Joined:
    Oct 28, 2014
    #1
    Since 8.1, all of my iMessages are being sent as my email, not as my phone number, so all of my contacts have two conversations per person. Any ideas how to fix?
     
  2. wongster macrumors regular

    Joined:
    Sep 27, 2014
    #2
    had the issue when i got the iPhone 6. i just had the other person send me a message with my phone number instead of the email. that fixed it.
     
  3. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #3
    1. Both of you need to erase your conversation.
    2. Go into Settings > Messages > Send & Receive - make sure the "Start New Conversation" setting is your number and not your email address.
    3. ???
    4. Profit.
     
  4. bgro macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    South Florida
    #4
    Go into settings -- messages - send and receive and make sure your number is checked off in the "start messages from" option
     
  5. Meathead1 thread starter macrumors member

    Joined:
    Oct 28, 2014
    #5
    I don't have a start messages from options. Only Apple ID and You can be reached by imessage at: and a list of email addresses. My phone number is also listed and checked.
     
  6. bgro macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    South Florida
    #6
    Turn off iMessage and wait an minute or two and turn it back on..see if that reset displays the the send from option
     
  7. Meathead1 thread starter macrumors member

    Joined:
    Oct 28, 2014
    #7
    Thanks. Did this and unchecked all emails attached to iMessage. Working now.
     
  8. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #8
    op this happenes from time to time been happening to me maybe once or twice a month since iMessage existed. Like others have said it helps to delete the conversation on both sides first. That solves it the majority of the time. My settings usually never change on their own I just assume it's a server glitch
     

Share This Page