Mid-2010 Macbook Pro is slow/laggy and makes a weird noise

Discussion in 'MacBook Pro' started by evilweasel47, Jan 3, 2013.

  1. evilweasel47 macrumors newbie

    Joined:
    Oct 13, 2010
    #1
    Hello members,

    I have a Mid-2010 Macbook Pro running Mountain Lion with all the latest updates. Everything was fine until 3 days back, when it started acting up. Moving the cursor was extremely laggy, and starting up any application takes forever. I also noticed a weird noise, more like a phone pulse dial, coming from the front. It repeats itself every 3 seconds, so I first thought it must be the HDD failing. But I have run all sorts of hardware tests but every test seems to infer that the HDD is working fine. Is it possible that the HDD is failing even though it doesn't show up on any test (like SMART status)? The Apple store nearest to me is more than a 3 hour drive away, so it's almost impossible to go there in person. Can anyone please help? Thanks in advance.
     
  2. PurrBall macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #2
    Totally possible. I'd back everything up ASAP just in case that is indeed the problem.
     
  3. mpayne2k macrumors 6502a

    mpayne2k

    Joined:
    May 12, 2010
    #3
    If you can afford the approx. $80 for 128gb or $140 for 256gb, I think you should consider upgrading to a SSD.
     
  4. evilweasel47 thread starter macrumors newbie

    Joined:
    Oct 13, 2010
    #4
    Thanks. I have a Time machine backup and a Carbon Cloner backup thankfully. I will probably get a SSD then.
     
  5. Idefix macrumors 6502

    Joined:
    Jul 10, 2012

Share This Page