Midi on Mojave

Discussion in 'macOS Mojave (10.14)' started by saxman211, Oct 25, 2018.

  1. saxman211 macrumors regular

    saxman211

    Joined:
    Jun 12, 2010
    #1
    I just updated to Mojave and my midi is not working correctly. There's no audio. In Logic, I can see that it's recognizing and telling me what chords I'm playing... but there's no sound. Can anyone help?
     
  2. Wando64 macrumors 6502a

    Wando64

    Joined:
    Jul 11, 2013
    #3
    Why do you think the problem is MIDI related? Are your speakers connected through MIDI?
    If you select your internal speaker for the audio output, can you hear any sound?
    Can you hear any other system sounds?
     
  3. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Try create a new MIDI AU and drag the MIDI data to that stem. Does it now play?

    Also try just playing anything with the musical keyboard (CMD + K) in a fresh stem. Anything there?
    --- Post Merged, Oct 25, 2018 ---
    Also do you use a DAC? The audio default might still be set for that.
     
  4. idealtracks macrumors member

    Joined:
    Mar 4, 2014
    #5
    I'm on Mojave, running latest Logic with an older Apogee Duet FW, and 2 midi USB devices: iRig keyboard and Logidy foot controller, all with no issues.
     
  5. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #6
    Also OP, are you on Logic 10.4.2? I'm running that on Mojave with no issues.

    I've seen occasional problems with MIDI before but it's literally just a case of creating a new track to troubleshoot.
     

Share This Page

5 October 25, 2018