Mini 2018 + Blackmagic eGPU = Screen Does Not Sleep


macrumors regular
Original poster
Feb 6, 2009
Hi. I have had a 2018 Mac Mini for a year or so. For most of that time I had it connected to a TB3 enclosure for my data drives and a Razor Core X with a Sapphire Radeon 580. That worked well, until I decided to try out the LG 5K display. With its TB3 connection only, I couldn’t get acceptable GUI performance directly off of a TB3 port (with the drive and enclosure and my eGPU on the farthest away TB3 ports). And manually checking the Get Info “preference eGPU” box seems unreliable at best.

The problem was I kind of fell in love with that lovely screen. So I decided I would try the Blackmagic eGPU to provide a satisfactorily responsive experience with the 5K — and it does well with that.

The issue is the screen never automatically goes to sleep anymore. This was not an issue with the prior GPU setup. I have checked the Activity Monitor setting for apps blocking sleep. None are “yes” entries. I have my computer set to never sleep anyway. Just want the screen to turn off and the computer to lock itself.

Any guidance? Thanks!