iPad mini Mini disconnecting from Wifi and prompting me for wifi password

Discussion in 'iPad' started by fdama, Dec 10, 2012.

  1. fdama macrumors newbie

    Dec 3, 2012

    I have had my iPad mini, my first apple product ever, for a week now and love it (screen could be better as 1,000s have said). However, I have a problem and I am not sure what the cause is. If the device is in standby for a period of time, it somehow disconnects from the wifi connection. When I take it out of standby, lets say in the morning after being in standby all night, I notice that the wifi icon on the black bar on top is not shown. To reconnect, I have to put in my wifi password. I always have to do this to reconnect. There was on occasion a few days ago where it managed to stay connected for a full day. I don't have this issue with any of my our other devices at home, all android and Blackberry tablets and phones. I called Apple and they asked me test it on a different network to see if it happens. But I currently do not have that opportunity.

    This issue is unacceptable and I am not sure as to whether this is a hardware issue with the Mini. I am also not sure as to whether it is any compatibility issues with my router which is an old, but popular linksys wrt54g.

    Has anyone experienced this issue? Or could anyone give me any advice on what action I should take before my 2 week returns deadline with Apple is up?
  2. radioking macrumors regular

    Nov 5, 2012
    Instead of selecting the network from the list, select "Other..." and enter your network manually. This should fix the problem.
  3. haruhiko macrumors 601


    Sep 29, 2009
    Exchange the mini for a new one. If the problem persists, I think you may need a new router. Judging from the model number your linksys may be very old which doesn't support modern encryption method like WPA 2 ;)
  4. fdama thread starter macrumors newbie

    Dec 3, 2012
    Thanks for the suggestion. I am trying this now. Why would this be the solution?
  5. ritmomundo macrumors 68000


    Jan 12, 2011
    Los Angeles, CA
    I had the same problem with my iPhone 4, ipad mini and my MBP (but not my MBA, ipad 1 or my iPhone 5, or any other non-Apple devices). I don't know why it happens, but this has also worked for me.
  6. radioking macrumors regular

    Nov 5, 2012
    It just is. I had the same problem with that router.
  7. Bdix macrumors newbie

    Nov 3, 2012
    I had them same problem with my 4. Changing the name of the network has worked for me. Someone on here suggested it. Mine was called "linksys" and I changed it to something unique and wifi hasn't disconnected since.
  8. fdama thread starter macrumors newbie

    Dec 3, 2012
    Looks like your suggestion is working. I have not lost connection since entering network details manually. Hope this helps others may experience this with this router. Thanks again. :)

Share This Page