Resolved MiniDP to Hdmi - Tv hides menu bar

sludeking

macrumors newbie
Original poster
Sep 28, 2011
23
0
Hi there,

Just got a new tv and hdmi adapter to minidisplayport.

I've connected and all, but the tv doesn't display the full "image/desktop". It cuts out the menu bar and a little on each side too.

I've tried changes the resolution on the tv (1080i, 1080p, etc) but get no luck.

I've tried checking and unchecking "overscan", but this doesn't help either.

As you can see from the screenshot, some of the top gets cut off.

Any help regarding this issue?

-Simon
 

Attachments

Last edited:
Nov 28, 2010
22,670
28
located
Could it be, that MIRROR DISPLAYS is selected?

System Preferences > Displays >> Arrangement >>> Mirror Displays (but know, that the display with the lowest resolution determines the maximum resolution used on both, thus one display will have a lower than native resolution, except when both displays have the same native resolution)
 

sludeking

macrumors newbie
Original poster
Sep 28, 2011
23
0
@simsala, thanks for the quick reply.

The mirror feature works fine; however, I don't like using mirror. I want to use it as a second display that doesn't cut off the sides.
 

waw74

macrumors 68040
May 27, 2008
3,532
345
what brand of TV?

try setting the aspect ratio (on the TV) to Just scan or something similar (go through the options).

i've found on my LG tv that naming the input to PC fixed all sorts of issues.
 

Lennyvalentin

macrumors 65816
Apr 25, 2011
1,429
783
Many TVs routinely underscan the HDMI input in case you feed it bad video that has things like closed caption information embedded into the video stream for example, which would then appear as lines of flickering noise at the top of the frame.

This is why TVs are generally unsuitable to be used as computer displays, and you're unfortunately out of luck if the TV does not have a "PC" or "Game" mode or similar that disables this underscanning. Go through the menus carefully and see what you can find. Maybe call up the manufacturer's customer support line and see what they say, if applicable.
 

sludeking

macrumors newbie
Original poster
Sep 28, 2011
23
0
what brand of TV?

try setting the aspect ratio (on the TV) to Just scan or something similar (go through the options).

i've found on my LG tv that naming the input to PC fixed all sorts of issues.
Hey. I tried setting the tv to Screen Fit/Scan, whatever it's called, and no luck while in OS X.

However, when I boot into my Boot Camp partition and have the screen set to Screen Fit then there is no clipping/cutting of edges.

??
 

chrisvee

macrumors regular
Jul 2, 2010
209
0
Winnipeg, Canada
I believe there is a slider somewhere in Mac OS that adjusts the amount of under/overscan - I don't remember where it is, but it's there somewhere. Also, be sure to set your Mac's resolution to the TV's native resolution (720p, 1080p, etc.).

There's this tool called SwitchResX that you could try. I haven't used it myself, but it's worth a shot if nothing else is working for you.


Hey. I tried setting the tv to Screen Fit/Scan, whatever it's called, and no luck while in OS X.

However, when I boot into my Boot Camp partition and have the screen set to Screen Fit then there is no clipping/cutting of edges.

??
I've also found that Windows 7 (Boot Camp) handles my external monitor better than Lion. I have no idea why..
 

sludeking

macrumors newbie
Original poster
Sep 28, 2011
23
0
@chrisvee

SwitchResX works like a charm. Only thing that has worked so far. Thanks loads for suggesting it. :)

I believe there is a slider somewhere in Mac OS that adjusts the amount of under/overscan - I don't remember where it is, but it's there somewhere. Also, be sure to set your Mac's resolution to the TV's native resolution (720p, 1080p, etc.).

There's this tool called SwitchResX that you could try. I haven't used it myself, but it's worth a shot if nothing else is working for you.



I've also found that Windows 7 (Boot Camp) handles my external monitor better than Lion. I have no idea why..
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.