Missing vecLib framework

Discussion in 'Mac Apps and Mac App Store' started by dguisinger, Jul 16, 2003.

  1. dguisinger macrumors 6502

    Jul 25, 2002
    Hey guys, I'm missing the framework vecLib (somehow). iTunes refuses to open, console prints a message saying:

    dyld: /Applications/iTunes.app/Contents/MacOS/iTunes can't open library: /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib (No such file or directory, errno = 2)

    I have double checked, the only thing in vecLib is a folder for headers....no actual binary. What can I do? It was running fine this morning. I've tried reinstalling twice, to no avail. I do not want to reinstall the OS if I dont have to. What can I do?
  2. MacManDan macrumors 6502

    Apr 11, 2003
    Which OS are you running? 10.2.7? If so, maybe someone with the same OS revision could send you the contents of that folder on their installation, and after a quick restart, maybe it would work. (That's not illegal right? since he IS running the OS already, just patching it up?) :)

    Anyway, I would offer .. but my Mac refuses to start up and I can't reinstall Jaguar (after the fact that they have replaced my hard drive already) .. :(
  3. dguisinger thread starter macrumors 6502

    Jul 25, 2002
    Heh, I'm running Panther unfortunately, so I don't know who I can turn to for that...assuming it has even changed... It was listed as /A/vecLib so it seems like a first version... The /A/ is to designate different versions so that it can maintain compatibility, right? Unlike DLL Hell....
  4. MacManDan macrumors 6502

    Apr 11, 2003
    I assume you are right. Seems like a nice way of organizing it, at least. There are several members on the forums that are running Panther beta and I'm sure they might be able to help you out a little better than I can. Although, since it IS a beta OS this may be a more difficult bug to pinpoint than simply replacing files. I would say try to get a hold of Apple (assuming you have a "legal" pre-release copy of Panther) and let them know. They may have a fix, or you may have stumbled across a bug they have not found yet. In either case .. backup your stuff and I hope you have another partition with Jaguar ... (just in case)
  5. dguisinger thread starter macrumors 6502

    Jul 25, 2002
    Haha, no I was the idiot who mis understood Apple's disk utility and accidently wiped out my machine a few days ago (Works a bit differently from FDisk), so I now only have one partition with Panther on it.

    iTunes worked great until I installed RealOne Player and December 2002 Developer Tools. Then I tried to use it again, and it didnt run.
  6. Dr-Ajax macrumors newbie

    Jul 30, 2003
    Missing veclib.Framework found!

    I'm not sure if you still need this, but I just had the same problems with panther and found a solution I'm not too confident about...

    I did a locate for veclib and found this entry...

    After backing up both vecLib directories, (the above and /System/Library/Frameworks/vecLib.framework) I created a symlink in /System/Library/Frameworks/ to the vecLib.Framework directory from the Accelerate.framework.
         > sudo ln -s /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/ /System/Library/Frameworks/vecLib.framework

    I double clicked on iTunes and voila, iTunes lives once again.

    YMMV and I probably fubared my computer, but I hope this helps.


Share This Page