Mojave changed standby behavior on MBA

Discussion in 'macOS Mojave (10.14)' started by kevo0822, Dec 15, 2018.

  1. kevo0822 macrumors 6502

    Joined:
    Jul 13, 2007
    Location:
    New England
    #1
    Since updating my 2015 MBA to Mojave, I've been getting significant battery drain while the laptop is "asleep." I used to have minimal battery drain when asleep... I would maybe lose a couple % over 24 hours, but now it's usually around 20-30% in 24 hours!

    It seems like the computer often won't enter a deep sleep/standby/hibernation mode. I think it happens most often when I close the lid while plugged in... and then unplug the computer after it's already asleep (but sometimes it happens when purely on battery power as well). Interestingly, I noticed some changes in the "Power" section of System Report. I've never seen "High Standby Delay" or "Standby Battery Threshold" listed there before, so it seems like Mojave changed how standby behaves on my MBA. Is anyone familiar with what these new changes are or how I can go about restoring the old behavior?
     

    Attached Files:

  2. niji Contributor

    niji

    Joined:
    Feb 9, 2003
    Location:
    tokyo
    #2
    its coincidental, but just a few days ago i purchased the new 2018 MacBook Air, after laying to rest my trusted 2015 MacBook Air.
    i did notice that on the old machine that i couldn't trust it to do a lot of background activity (such as automatic backups to Time Machine) anymore while on battery.
    and, here is the interesting thing: the new machine really just sips power when not actively being used. i can wake up to it being only 2% to 3 % reduced battery from the night before.
    the new Airs have been marketed and reviewed with this capability.
     
  3. wegface macrumors member

    wegface

    Joined:
    Jul 15, 2018
    Location:
    Portugal
    #3
    In terminal you can adjust these values with the command:
    pmset

    for example---- (to alter setting only while on battery--- pmset -b standbydelay 1800)
    value at the end is in seconds, adjust to your requirements...
     

Share This Page