Mojave TM on High Sierra shared drive?

Stephen.R

macrumors 68000
Original poster
Nov 2, 2018
1,617
1,243
Thailand
Hey all,

I’ve reurposed my old 2011 MBP as a home “server” to run iTunes etc, and it’d also be nice if I could use it to share a drive for a Time Machine network share.

I’ve tried sharing both a whole disk and a folder on it, with the TM option set in the shares “advanced” dialog, and tried authenticating both with my username/password and via Apple ID - I can mount the share in finder and write changes, it lets me select the share in TM setup but when it tries to do the first backup it fails with auth failure.

Is this a known issue? I notice the apple doc for Mojave says the drive should be formatted as APFS but because it’s spinning rust on High Sierra it’s still HFS+. This presumbly relates to the host sharing the disk though, not the client.

Any thoughts/tips would be appreciated.
 

casperes1996

macrumors 601
Jan 26, 2014
4,190
2,043
Horsens, Denmark
Is this a known issue? I notice the apple doc for Mojave says the drive should be formatted as APFS but because it’s spinning rust on High Sierra it’s still HFS+. This presumbly relates to the host sharing the disk though, not the client.
Wasn't really sure what was what in your setup here, but Time Machine is not supported on APFS drives yet, and must be on HFS+
 

Stephen.R

macrumors 68000
Original poster
Nov 2, 2018
1,617
1,243
Thailand
Sorry I should have been clearer, I typed it on my phone but now I can really type let me be more specific:

There are effectively two computers involved here: a 2011 MBP17 running High Sierra (latest supported OS) and a 2018 Mac mini running Mojave.

The laptop has amongst other things, a 5-bay SATA case connected to it. One of the drives in it is a 2TB spinning rust drive, formatted as HFS+. This drive was used as a local TM target when the case was connected directly to the Mini, and now is a local TM target for the MBP.

What I want to do now, is share a directory (or the root of the drive, I really don't care) of that drive for the mini/any other Mac on the local network to backup to (I know it won't resume the old backups from when it was direct connected that's fine too).

According to Apple (https://support.apple.com/en-au/guide/mac-help/use-a-shared-folder-with-time-machine-on-mac-mchl31533145/mac) on a Mojave 'host' for this to work the local disk must be APFS. In High Sierra it's not even an option to convert a spinning rust disk to APFS, and this other guide which is essentially the same instructions for High Sierra, doesn't mention APFS (https://rafikitechnology.com/2017/11/10/how-to-share-folder-as-time-machine-backup-destination-in-macos-high-sierra-version-10-13-1/)


It all *seems* OK, right up until it tries to do the first backup, and then it fails with an authentication error, which I had assumed was actually a permissions error, but I have access to the share via Finder to create files etc. I also had a weird issue where the Sharing prefs wouldn't retain the change if I added my own user account with explicit read/write permissions - it'd be gone every time I re-opened Sharing. This does seem to have been a permissions issue as I've got it to retain it now after making my user account the owner for the drive and it's contents.
 

Brian33

macrumors 6502a
Apr 30, 2008
762
43
USA (Virginia)
Odd, there should be a way to get this to work. You don't mention it, but on the Mac Mini, you'd have to go into SystemPreferences-->Time Machine and select a backup destination, right? I'm curious if at that time it asks for any sort of password. I use TM with a Time Capsule, and that's the point when it would ask for the TC's disk password, and (presumably) store it in the keychain. Seems like in your setup the TM process would need the MBP user's account password to attach the share.
 

Stephen.R

macrumors 68000
Original poster
Nov 2, 2018
1,617
1,243
Thailand
It does ask for auth, and even checks it works at the time. I’ve tried it using a regular local username+password and using appleid auth, neither work.