Monitor sleep setting still seems to put system to sleep

skymacdave

macrumors newbie
Original poster
Jun 28, 2018
8
0
USA
I have my monitor sleep setting set to 30 minutes (of inactivity I'm assuming, and after the screensaver activates), and "Prevent computer from sleeping automatically when the display is off" checked, and "Put hard disks to sleep when possible" unchecked, but when I come back from lunch or something, and the monitors are off, moving the mouse and hitting the keyboard doesn't wake anything... I have to hit the power button.

1580852657640.png


I can't tell if the Mac system is asleep (it's an iMac 2017) or just the monitors, but regardless, the monitors going to sleep shouldn't shut off mouse or keyboard wake.

Am I missing something here? Or what's the solution? I'm on Mojave because updating to Catalina will probably break some apps I'm using, so I'm not quite ready to update yet.