More than one window of safari. How to close?

Discussion in 'Mac Apps and Mac App Store' started by camardelle, Aug 26, 2012.

  1. camardelle, Aug 26, 2012
    Last edited: Aug 26, 2012

    camardelle macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #1
    I've somehow managed to open two seperate safari applications and I only need one on my iMac. How can I close the other one permanently? I've hit the red x but it still shows up when I right click on the icon in the dock? And after a reboot, I click on the dock icon and it brings up two separate applications of safari.

    Any assistance will be appreciated. I've searched her on MR but haven't come up with a response which I'm sure will be really simple.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Does that mean, you have two Safari applications open (two Safari icons in the Dock on the left side of the divider, two Safari icons in the Application Switcher triggered via CMD+TAB)?
    If so, right click on one of them and select "Show in Finder" and do the same with the other icon and see, if they go to the same application file.

    If you have two windows open, can you quit one window via CMD+W?

    I guess, you either have Mac OS X 10.7 Lion or OS X 10.8 Mountain Lion?

    And would it be possible to record your screen via QuickTime Player > File > New Screen Recording and share the saved movie via uploading it somewhere (as a file via file sharing service (Dropbox?) or video sharing service (YouTube))?
     
  3. camardelle thread starter macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #3
    Looks like I fixed it.

    Not sure what I was doing (not the first time) but when I clicked on "window" above the screen, there was an option to merge all windows and that looks like it did the job. Thanks for the swift response Sim. This place rocks!
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Check this box in System Preferences / General tab.

    [​IMG]
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    So it was a window "issue". And the part above the windows, the white bar with the :apple: and File and Edit and so on is called the Menu Bar, as it contains the menus for the open applications.

    To learn more about Mac OS X: Helpful Information for Any Mac User by GGJstudios


    ----------

    So nice of Apple to include that checkbox. And it is easily found. Man, they should include beginner tutorials nowadays into their OS, maybe instead of the lost welcome video, they show a video of where to uncheck those simple things, as it still causes a lot of confusion (I often forget it is there, but then again, I am still using Mac OS X 10.6 Snow Leopard).
     
  6. camardelle thread starter macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #6
    Running 10.7.4 and I do not have that box, My preferences box gives the option: Restore windows when quitting and opening apps.

    Same thing? It's currently checked.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Uncheck it and you will be good to go!

    My cap is from Mountain Lion and they changed the wording/functionality to make it more clear what is happening. Sorry... did not realize you had Lion. :eek:
     
  8. camardelle thread starter macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #8
    Thanks for the help everyone. I really appreciate everyone's assistance.
     

Share This Page