Mountain Lion can't see 2.4GHz wifi SSID, but 5GHz

Discussion in 'OS X Mountain Lion (10.8)' started by niotio910, Mar 14, 2013.

  1. niotio910 macrumors newbie

    Jun 19, 2011

    I just bought a new router dual-band Asus rt-n56u. I set it up with 2 SSIDs 2.4GHz and 5GHz. All bands are configured with WPA2 encryption

    I installed the latest mountain lion on my MBP late 2011, and I didn't have any issue with the old router. However, the wifi issue has started to happen since I bought the asus router. The problem is that when I start up my macbook, I cannot see 2.4GHz access point on the list of AP, but I can see the 5GHz. However, whenever it gets connected to the 5GHz AP, then I can see the 2.4GHz AP appearing on the list.

    I don't have any problem with my windows laptop, iphone and ipad. Another problem is that, I don't use the 5GHz connection with ML because it's very sluggish.

    I know that there're a lot of Wifi issues with ML. I tried different solutions suggested but I can't solve the problem. One thing I haven't tried is to clean install the ML.

    Any suggestion will be appreciated!
  2. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    When you setup the 5GHz did you use the 100+ channel range? If not for the 5GHz change the channel to 100+ channel range. See if that helps.
  3. niotio910 thread starter macrumors newbie

    Jun 19, 2011
    I set different channels available in my router (US, Europe, Taiwan ...) but it didn't help :(

    I just did clean installation and upgraded to 10.8.3, but it didn't help either.
  4. 00maximus macrumors newbie

    Mar 30, 2013
    I have the same issue, I never noticed it since my iMac is always connected to 5Ghz WiFi and it works fine, but it cannot connect to 2.4Ghz. I've tried everything I found on the web but no luck..

    Actually I can see both the 2.4Ghz and the 5Ghz WiFi networks, and can connect to both, but when I connect to the 2.4Ghz even though it says that it is connected, with an IP address and all the rest I cannot ping the router. If I simply switch to the 5Ghz WiFi then it works perfect..

Share This Page