Apple TV MovieBox 2.8-3.1 Airplay Glitchy/Choppy

Discussion in 'Jailbreaks and iOS Hacks' started by brushpicks11, Dec 16, 2014.

  1. brushpicks11 macrumors newbie

    Joined:
    Mar 29, 2014
    #1
    My moviebox runs fine and I can stream it via airplay to my apple tv 3 on HD with no sound or quality problems but the video has this weird choppiness to it almost like it is hiccuping rhythmically. I've tried different streams, different quality and nothing works just that same glitchiness.

    It's not my internet because HD airplay works flawlessly in safari, video app, and youtube. It's just moviebox. Doesn't matter if I download the video either.

    Anyone else having this problem/know why this problem exists. I'm on ios7.1 and even ios 6 has this issue. I've tried different versions of moviebox on iphone 5s, 3gs and ipad 3 with no luck. Any help would be greatly appreciated.

    Thanks.
     
  2. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #2

    Streams great for me.

    Is this on a jailbroken device?

    Are you using AirPlay with Bluetooth or wifi?
     
  3. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #3
    Thanks


    Thanks for your reply.

    I have tried it on jailbroken 5s, ipad 3 and non jailbroken 3gs. The fact that no one else is having this problem might be attributed to my router. I have 2.3megabytes download speed comcast internet going through my netgear WNR2000v4 so maybe I need dual band 5ghz router? What kind of router do you use for your moviebox + airplay?

    And i'm using wifi. How do you airplay moviebox via bluetooth? Didn't know that was possible
     
  4. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #4

    I have the Apple TV hooked up to the router with an Ethernet cable. If I try over wifi it's really choppy.
     
  5. OutSpoken macrumors 6502a

    Joined:
    Jun 9, 2009
    Location:
    UK
  6. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #6
    Yes

    I will try ethernet tomorrow. I will try anything before I upgrade my router. And I heard that you can play moviebox through chromecast but you have to find the downloaded moviebox file in ifile and play it that way. Kinda inconvenient IMO but cool if you already have a chromecast anyway.
     
  7. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #7
    Still Doesn't Work

    I've hooked an ethernet cable to my Apple TV and movie box stream still is hiccuping. No one else has ever had this problem? Their moviebox stream is smooth?

    I'm thinking I may need to get a replacement apple tv
     
  8. Gifty74 macrumors newbie

    Joined:
    Dec 19, 2014
    #8
    I'm having the same issue with Moviebox. I have an ATV 3 and I have a pretty decent dual band Netgear router. Both the ATV and the 'i' device are on the same network, both connected to the very fast 5 ghz band. I get around 105-110 Mbps download on my comcast Blast service. So no bandwidth issues here. But, my Moviebox has a real slight stutter after a few minutes. Some people don't even notice it, but sometimes it gets real noticeable and everyone notices. I've tried lots of things, not sure what to do next. So, not sure it's your setup or just a problem with some peoples configurations on their iPhones or iPads and how they communicate with the ATV via AirPlay.
     
  9. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #9

    Really smooth here. Also when I use my phones hotspot to run moviebox on iPad and appletv.

    iOS 8.1.2 jailbroken with Taig.

    iPhone 5S

    rMini. Moviebox 3.1.
     
  10. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #10
    Hmm


    I don't get why mine isn't smooth then. I don't think updating my phone to ios 8 will make a difference. Anyone having this issue on ios 7.1?
     
  11. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #11

    Where did you get your movie box app?

    I got mine at Dtathemes.

    Make sure you are not connecting over Bluetooth. That makes it choppy unless you are super close to your Apple TV.
     
  12. eprisencc macrumors member

    Joined:
    Sep 15, 2014
    #12

    Got mine on ipawind. They got the iPhone 6+ optimize version on there.
     
  13. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #13
    See I've tested different movie boxes one from cydia one from vshare and one from right off some website. They all seem to have problems. It isn't the most noticeable thing in the world it just seems like there's not enough power on the Apple TV to make it smooth almost as if you have you laptop set to a power saving mode and try to watch a 1080p video on YouTube with multiple tabs up. Makes the YouTube video fairly difficult to play without hiccups.

    I've even tried setting the resolution on the tv to 720p considering that's the high quality on movie box anyway. Doesn't make a difference

    I've also noticed that with tv shows on movie box on high quality there's no hiccups. And now some movies play smoother than others. It's very strange. I'll just try to live with it maybe one day I'll do something or nothing and it'll change.
     
  14. LivingLegnd macrumors newbie

    Joined:
    Dec 23, 2014
    #14
    Same problem

    I notice it all the time. Was hoping to find an answer coming here. I run movie box with jailbreak, without, iPhone 6 plus, iPad Air, newest version, and even the old moviebox on iOS 5 with a first gen iPad... Same problem across the board. The only trick I have learned is to briefly reset the AirPlay back to iPad and then again to your appletv and it will briefly fix the problem. But several minutes later it will return.

    This drives me nuts.

    And I really can't believe that no one else is experiencing this.

    Please help.
     
  15. XmeX macrumors regular

    Joined:
    Sep 21, 2014
  16. brushpicks11 thread starter macrumors newbie

    Joined:
    Mar 29, 2014
    #16
    What router do you guys with the same issue use?
     

Share This Page