Movies not purchased in iTunes not show up on Apple TV

Discussion in 'Apple TV and Home Theater' started by LAWandHOARDER, Nov 11, 2014.

  1. LAWandHOARDER macrumors newbie

    Joined:
    Feb 13, 2013
    #1
    Hopefully you guys can help me out here!

    If I download a movie outside of iTunes and add it to my iTunes library, how do I get it to show up on my Apple TV? It is only showing movies that have been purchased on iTunes.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. kemperman macrumors regular

    kemperman

    Joined:
    Jul 15, 2009
    Location:
    UK
    #3
    With movies downloaded outside of iTunes/ripped from DVD/BR normally you have to go into computers>movies and it'll show up there
     
  4. erinsarah macrumors regular

    Joined:
    Mar 17, 2011
    #4
    Look under home movies

    Yeah, I had this problem for a while and discovered that when you drag the .MP4 file into iTunes it categorizes it as "Home Video" instead of "Movie". Search for the file in itunes and, once you find it, hit Get Info. Go to the Options tab (I think...writing this from memory without a Mac in front of me) and there's a dropdown box for the type of video it is. Change from Home Video to Movie. That should solve the problem. And, as far as I know, there's no way to change the default to Movie.
     
  5. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #5
    Run the movie thru something like Subler and it will properly tag it for iTunes usage. After ripping any of the movies I own, I run them thru Subler to update all Metadata (and add proper images) before loading it into iTunes.
     
  6. CelestialToys macrumors 6502

    Joined:
    Aug 4, 2013
    Location:
    up above the streets and houses
    #6
    Plus one for Subler. Great bit of software and it's free.

    Great for getting metadata and artwork on both movies and TV shows as well as being able to add/remove subtitles, remove unwanted audio tracks etc etc
     

Share This Page