Mp3 issue.. song ends before the end of the song. I can skip past and its fine

Discussion in 'iPod' started by Cryptic1911, May 1, 2008.

  1. Cryptic1911 macrumors member

    Joined:
    Mar 11, 2008
    Location:
    Connecticut
    #1
    Anyone ever had this issue?

    I have some songs that are like ~5 minutes long, but they will end after a minute or two. If i skip past the exact second that it "ends", it plays the full 5 minutes. For example I have one that ends at 1:53, but if i hop to 1:54 it will play all the way to the 5:00 mark or wherever it should end


    :confused:
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Select song, get info (command i), you can see if end time is set improperly by some other user (or from where you copied the music).
     
  3. Cryptic1911 thread starter macrumors member

    Joined:
    Mar 11, 2008
    Location:
    Connecticut
    #3
    oh wow, I never knew that was possible.. I'm at work now so I can't check the files I have at home, but that could definately be it

    thanks for the info
     
  4. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #4
    Sounds more likely to be a corrupted file. I don't think skipping past an "end time" tag will play the rest of the file, I think it will just end (as though you positioned the cursor right at the end point).
     
  5. Cryptic1911 thread starter macrumors member

    Joined:
    Mar 11, 2008
    Location:
    Connecticut
    #5
    hm, I think you're right.. I tried this at work by setting a file's end time then clicked after it and it just went to the next song
     
  6. Cryptic1911 thread starter macrumors member

    Joined:
    Mar 11, 2008
    Location:
    Connecticut
    #6
    ok i found out how to fix them.. I downloaded a program called mp3val for windows and loaded it in my vmware'ed XP install and it fixed the files in about a half a second. they play flawlessly now..


    Err.. ****, nevermind.. that didn't work. They play fine in VLC now, but not in Itunes. wtf?
     

Share This Page