MS Word 2011 on Mac OS X: Where is a good place to ask questions?

Discussion in 'Mac Apps and Mac App Store' started by john236, Jul 8, 2014.

  1. john236 macrumors newbie

    Joined:
    Jul 8, 2014
    #1
    I have microsoft Word:Mac 2011 running on my Mac (OS 10.7.5)
    When I click on the icon, it opens the past 26 documents, which I do not want.
    Can anyone suggest a forum where I can ask questions about its behaviour, and about changing its behaviour?

    Thank you.
     
  2. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #2
    This sounds like OS X's autosave/resume feature. You need to close the documents in order to prevent them from reappearing when you start Word. The command to close a document is Command-W (not command-Q, which quits the application) or you can click the red-x button of the document window.

    Alternatively you can restore the older system behavior of closing all documents when quitting an application by checking a box in System Preferences --> General.
     
  3. nparmelee macrumors 6502

    Joined:
    Jan 23, 2008
    #3
    Have you closed the documents when Word was open? Normal behavior is to open all the documents that were open when Word was last closed. If you are saying that there are no documents open when you closed Word and the next time you open Word it opens the 26 most recent documents, that I haven't seen, sorry.
     
  4. frenetic macrumors regular

    Joined:
    Feb 11, 2004
    Location:
    Amsterdam
    #4
    And if you manually close each document (so closing the documents, not the app), does it still exhibit the same behaviour? MS Word by default opens all the documents you last had open.
     
  5. john236 thread starter macrumors newbie

    Joined:
    Jul 8, 2014
    #5
    Hello,
    Thank you all for your posts.
    Yes. it does sound like normal behaviour and normally I wouldn't object. But I have carefully manually closed each individual file, and then manually quit the application. Then I have run Microsoft's auto-update function. Then I have clicked on the Word icon - and all 26 files open.
    So it seems that somewhere word loses the fact that I have carefully closed each file, and treats all the files as 'open'.
     
  6. frenetic macrumors regular

    Joined:
    Feb 11, 2004
    Location:
    Amsterdam
    #6
    OK then try this:

    Quit Word

    Open the library folder of your home folder (in principle this is hidden, but in Finder select "go to folder" and type /Users/xxx/Library with xxx the name of your home folder.

    Go to folder "saved application state"

    Take out your com.microsoft.Word.savedState and put it on your desktop.

    Open Word - in principle there should not be 26 files.

    One question, though: why run first the auto-update app?
     
  7. john236 thread starter macrumors newbie

    Joined:
    Jul 8, 2014
    #7
    Thanks for the suggestions!

    In answer to the query, the actual flow of events was:
    - I get the message that Auto-update will run.
    - I do not, in general trust MS products to behave nicely. So I went to the (open) MS Word app and saved and closed the 15 open files.
    - Then I quit the app.
    - Now I thought, I can run the Auto-update and be safe from any MS 'funnies'.
    - So I was upset, and surprised, when MS word proceeded to open 26 files (including files I had closed days ago)

    Ah! The next time the Auto-update message comes, I shall look into these folders..
     
  8. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #8
    IMHO you're "blaming" the incorrect source of your issue. You have Lion, which I'm so happy to be rid of, and I believe Lion's "Resume" could be the source of your grief. For me and my small business, Lion was notoriously nasty with permissions - settings would be re-enabled, file ownership would be forgotten... :mad: :mad:

    Pause while I get a stiff drink...

    Better now. I had exactly this issue with Lion so many times I considered switching to Windows or Linux. I discovered that disabling "Resume" worked wonders - quit Word, navigate to System Preferences>General, and uncheck the "Restore windows when quitting and re-opening apps" checkbox. This disables Resume for all applications. Then hold your breath, get a drink, then restart Word. Fingers crossed.

    Word 2011 was/is a Cocoa/Carbon hybrid. I had problems with running Office apps in Rosetta as well.

    If that isn't it - it could be that you've corrupted your Normal Template - also a recurring issue with Lion and permissions/ownership, so consider quitting Word, deleting the Normal template, and restarting Word.

    Moving to ML and now Mavericks, I have no more problems like this. The best location to pose this questions is MS's own forums IMO. Good luck.
     
  9. john236 thread starter macrumors newbie

    Joined:
    Jul 8, 2014

Share This Page