Music suddenly stops playing, gets skipped over (iPhone 4S)

Eradik

macrumors regular
Original poster
Jul 10, 2011
130
10
Pacific Northwest
Anyone else had this problem? I was hoping by re-downloading all my music it would fix it but that seems to have done nothing.

For example: Two days ago I downloaded two Toby Keith songs from the iTunes store. I didn't do anything to my phone (including turning it off), when the next day suddenly the songs won't play. Every other song plays fine, except the two Toby Keith songs. At first I thought it was my car stereo, but it wouldn't play on the iPhone either. Plays fine on iTunes.

The only fix is to delete the song and re-download it. I would have normally thought it was the song download, but rewind to a few weeks ago, and my entire Hollywood Undead Swan Songs CD (also bought from iTunes) wouldn't play. It was at this point I deleted all my music and resented it.

I tried resetting phone, resetting settings, deleting all music and starting again, and it even did it through a restore.

Is this a bug? Is it a bad phone?

Thanks
 

michaelsaxon

macrumors 6502
Nov 15, 2006
335
5
This is happening to me and it is happening a lot. If I have to download these songs again, I will be doing a lot of downloading.

I have entire albums that refuse to play or some where it will skip some, play others, etc. All are legitimately purchased.

Very irritating. Not sure if it is iOS update or the fact that I signed up for Match.
 

GraphicsGeek

macrumors 6502a
Sep 19, 2008
533
0
Unsync all of your music and resync. If that doesn't work, do a restore from backup. I had the same problem.
 

Caliber26

macrumors 68000
Sep 25, 2009
1,850
1,400
Orlando, FL
Unsync all of your music and resync. If that doesn't work, do a restore from backup. I had the same problem.
Yep... this will work. Once I got the iPhone 4S, I noticed that about 90% of my iTunes-purchased songs were not playing on my iPhone. They played fine on my computers, however. So what I did was uncheck the songs in iTunes and made the iPhone sync only the checked content. Once synced, I checked those songs once again and synced everything and those songs now play on my iPhone without a problem. It, is indeed, a VERY annoying bug.

(you can also just remove those problem songs from iTunes and place them on your desktop and sync without them, and then put them back into iTunes and sync again)
 

GraphicsGeek

macrumors 6502a
Sep 19, 2008
533
0
Yep... this will work. Once I got the iPhone 4S, I noticed that about 90% of my iTunes-purchased songs were not playing on my iPhone. They played fine on my computers, however. So what I did was uncheck the songs in iTunes and made the iPhone sync only the checked content. Once synced, I checked those songs once again and synced everything and those songs now play on my iPhone without a problem. It, is indeed, a VERY annoying bug.

(you can also just remove those problem songs from iTunes and place them on your desktop and sync without them, and then put them back into iTunes and sync again)
Or you can just uncheck the box to sync music, sync the iPhone, then check the box again and sync. No need need to move music around on your computer or figure out which tracks are causing a problem.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.