My 1.1.1 upgraded phone from 1.0.2 iunlock!

Discussion in 'iPhone' started by spinstorm, Oct 14, 2007.

  1. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #1
    Some of you may have seen my post yesterday about messing up my iPhone and not being able to restore it.

    Well eventually I restored it to 1.0.2 then I decided I would have a go jailbreaking and activating 1.1.1 - BIG MISTAKE!

    I was up all night and although I unlocked it using IPSF in 1.0.2 and updated it to 1.1.1 so it was still unlocked I could not jailbreak OR activate it.

    I was stuck - and I doubted I would have it fixed for several days as I was waiting for a GUI jailbreak and unlock.

    However it turns out there was an error in the Wiki I followed and it was updated a few hours ago so I thought I would have a go...

    Despite thinking I was doing it all wrong and getting wierd errors I peservered and eventually it was done!

    1.1.1 jailbreak'd, activated and unlocked with 3rd party apps and all the cool new features.

    [​IMG]

    Was it worthit? absolutely.

    Do I recommend anyone else tries it who isn't a hacker? NO.

    It took forever and I was sure I broke the phone- I consider myself VERY LUCKY it worked.

    My advice is wait for an easier way to do it! But for the time being I am going to enjoy the sense of satisfaction that you get from hacking Apple and beating them at their own game... and no I am not a hacker and I had no clue what I was doing!
     
  2. PDE macrumors 68020

    Joined:
    Nov 16, 2005
    #2
    that's great news! Could you please post what methods you used and any other pieces of advice for those who want to do this.

    Thanks!
     
  3. spinstorm thread starter macrumors 65816

    Joined:
    Sep 14, 2007
    #3
    The following links contain all the information:

    http://www.modmyiphone.com/wiki/index.php/Dev_Team_Jailbreak_1.1.1_from_1.0.2_Windows

    http://iphone.fiveforty.net/wiki/index.php/Jailbreak_1.1.1

    I basically combined the information from both of them to get to where I was.

    The second guide mentions the mistake with process under the "install SSH" bit- once I removed those files the process finished but I got a "0" at the end of the dialogue - so I looked at the first guide and it told me how to correct that.

    I used Putty and WinSCP in Windows to do everything else the process showed.

    I installed the BSD subsystem using the command prompts but when I started my phone installer told me that it could not install 3rd party apps without it - so that obviously failed for some reason.

    Maybe I would have activated the phone sooner - because its the last stage in the guides and I don't think it has to be the last stage - once the phone is jailbroken and SSH is working you can do the online activation procedure (from the first guide) and it will work.

    A word of warning I had to copy itunesmobilelibrary.dll into the same folder as the activation exe and even then when it was done I got an error saying it had failed - but I reuploaded the lockdown file and restarted and I was in and everything worked!

    If anything I said there confuses you after reading the guides then don't do it!

    I am still feeling confused and my iPhone works! :D
     
  4. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #4
    Cheers to you! im getting prepped to do the same tonight, but im holding out on the unlocking part for now. Let's hope something simple comes out quickly, i don't want to kill the phone again.
     
  5. DanBUK macrumors regular

    Joined:
    Oct 9, 2007
    #5
    @ Spinstorm: Congrats that you have got it working and good photo- I would have been up all night panicing too!

    I am going to jailbrake my virgin 1.0.2 arriving today :D then pay £34 for the iPhoneSimFree unlock and upgrade to 1.1.1 and then jailbreak once more.

    FreeOuriPhones has a really simple procedure for this and the feedback on howardforums suggests it works.

    I reckon at this stage for the non-hackers this is the best method. What do you reckon?
     
  6. carfac macrumors 65816

    carfac

    Joined:
    Feb 18, 2006
    #6
    That one worked great for me!
     
  7. spinstorm thread starter macrumors 65816

    Joined:
    Sep 14, 2007
    #7
    Are you referring to using WINstaller? As I do NOT think that works on 1.1.1

    If you mean another method then give me a link as I would like to see.

    Currently as far as I am aware the only way to jailbreak is to follow the DevTeam guide and use iphuc, and WinSCP and Putty for SSH on Windows and do the command line prompts then fiddle with the activation using the online method.

    If you are talking about how to jailbreak 1.0.2 then winstaller will do that and activate it although personally Winstaller crashed on me and messed up my iphone in the first place... AppTapp seems a much safer method for jailbreaking and activating that WinStaller and it is MUCH easier when uploading IPSF.

    If you head to www.gizmodo.com and do a search for iPhone you will find one of the news stories shows the guy downloading IPSF directly from a tinyurl address using installer and then unlocking... you will have to find the video and watch it to figure out the address like I did (I know I should have written it down!).

    And then you have to do the preparation to jailbreak before you go back to 1.1.1 and follow the instructions.

    It is not an easy process and I am surprised there is NO GUI yet for it on 1.1.1.

    However if I am wrong and there is a GUI now then let me know!
     
  8. spinstorm thread starter macrumors 65816

    Joined:
    Sep 14, 2007
    #8
    I decided to add the international keyboard to my iphone.

    I thought the worst that could happen is that my phone would crash and id have to restore the original file I changed to add the keyboard...

    Well I restarted my phone and after about a minute when it started it said it was an iPod in the corner!

    Worse than that it would crash immediately!

    My ONLY option was to restore the iphone to 1.0.2 which was easy enough although I had to put it into restore mode by holding the buttons down first and then I was back in 1.0.2 unlocked/JB/Activated.

    I decided to go back to 1.1.1

    BIG MISTAKE!

    It only took me a day to fix but I had errors I never even got the first time.

    And my blood pressure is through the roof!

    So the moral of the story is:

    Its STILL more hassle than its worth - I would love the international keyboard but NO WAY am I taking the chance again.

    I can live with US style dashes in my phone numbers as it works that way!

    Still waiting for a GUI that does all the hard work - when there is one out then maybe mistakes will be easier to deal with!
     
  9. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #9
    Strange i've had no issues whatsoever since adding the International preferences (Keyboard, Language & Region support)
     
  10. spinstorm thread starter macrumors 65816

    Joined:
    Sep 14, 2007
    #10
    I probably did it wrong - so thats what caused the issue BUT as it messed up my iphone and took me another day to fix I really am fed up with hacking it - I just want it to work and IT DOES!

    I copied the file off the phone (if your wondering what I did) and converted it to xml then I copied it to notepad and changed the false to true under international then saved it with the original file name and it started up and became an iPod that crashed.

    What was really odd though was that even WHEN I deleted the hacked file and put the ORIGINAL back it was still ****ed! thats what is even stranger to me!

    When a GUI jailbreak/activate is out then I may try again but in the meantime the manuel process takes so long I just do not want to risk it again at this time!
     

Share This Page