My 2,W,S amd X keys not working on my ibook g3. What's the problem

Discussion in 'PowerPC Macs' started by iluvgr8tdeals, Jun 20, 2009.

  1. iluvgr8tdeals macrumors member

    Apr 22, 2009
    I have been using my restored ibook for about 3 months now with no problem. One day, I found out that my 2, w, s, and x keys did not work. The other keys work and the computer otherwise functions without a problem.

    I used my imac keyboard using the usb port, and it worked perfectly. What could be the problem. Will replacing the keyboard help?

    Thanks in advance.
  2. r.j.s Moderator emeritus


    Mar 7, 2007
    Try resetting the PRAM ... Command-Option-P-R on boot.
  3. crazyrog17 macrumors regular

    Jan 13, 2009
    This happened to an old Compaq laptop I had. It seems one of the traces in the keyboard broke somehow, so it rendered the 3 E D C row dead. Same thing could have happened to your iBook. I suppose the best thing to do would be replace it, or get used to using an external keyboard.
  4. iluvgr8tdeals thread starter macrumors member

    Apr 22, 2009
    I replaced the keyboard...

    I tried to reset the PRAM as advised, but I ended up just replacing the keyboard that I bought on ebay! I am leaving an answer for anyone who might find themselves in this predicament in the future!

Share This Page