My Air falls asleep with lid closed and bluetooth keyboard and mouse connected

Discussion in 'MacBook Air' started by Johnny McCash, Jan 14, 2014.

  1. Johnny McCash, Jan 14, 2014
    Last edited: Jan 14, 2014

    Johnny McCash macrumors newbie

    Joined:
    Jul 17, 2013
    #1
    Hello :)

    Annoying problem here. I bought an Apple bluetooth keyboard and a "LogiLink" bluetooth mouse. They both work perfectly with my Air (2013 13", 10.9.1), but when I close the lid to use just my Dell screen via a Thunderbolt-to-DisplayPort adapter, the system falls asleep.

    I've set up bluetooth in preferences to allow waking the computer from sleep, and this also works — once!

    If I have the laptop on and I'm using it with my bluetooth HIDs and then close the lid, it falls asleep. I can then tap a key on the keyboard or click my mouse and it will wake. But I only have some ten or twenty seconds, then it falls asleep once again, and this time I can only wake it by opening the lid...

    What's going on? It's pretty frustrating :'(

    EDIT: This is while on battery — I can't test with the power adapter attached as I leave it at work on weekdays...
     
  2. lostgear macrumors member

    Joined:
    Nov 9, 2010
    #2
    This function only works when plugged into a power supply. While on battery power it will always sleep when the lid is closed.
     
  3. Dyn Tawel macrumors newbie

    Joined:
    Jan 8, 2014
    #3
    That's Right

    ...unless you change energy saver settings to stop it sleeping with the lid closed.
     
  4. Johnny McCash thread starter macrumors newbie

    Joined:
    Jul 17, 2013
    #4
    How would you do that?

    And also, this doesn't happen if I have a USB Apple keyboard attached, so why would this be any different?
     
  5. Dyn Tawel macrumors newbie

    Joined:
    Jan 8, 2014
    #5
    Sorry, scratch the above. Just checked and that doesn't work.
     
  6. Johnny McCash thread starter macrumors newbie

    Joined:
    Jul 17, 2013
    #6
    So, nothing to do but return the keyboard to Apple?
     
  7. joshi3joshi macrumors regular

    Joined:
    Oct 1, 2007
    #7
    try using an application called 'No sleep" which causes your macbook to stay awake even while the lid is closed.

    https://www.macupdate.com/app/mac/37991/nosleep
     
  8. Dyn Tawel macrumors newbie

    Joined:
    Jan 8, 2014
    #8
    or just bring the power adaptor home with you:)
     
  9. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #9
    if you insist on doing this then you need to install NoSleep or something like it.
    I use it and i love it.

    unplugging the power while TB is plugged in will put the computer to sleep...functioning as it's supposed to. it frustrated me a bit at first as well, but i got used to it.

    NoSleep is the way to go. Ideally you should bring your power cord home with you or buy another one, but that's up to you.

    i mainly use NoSleep to close the lid so i can read/study with music on but being less tempted to play on the internet...i generally use it while the computer is plugged in, but it will work both ways.
     
  10. Johnny McCash thread starter macrumors newbie

    Joined:
    Jul 17, 2013
    #10
    I tried no sleep (had already tried caffeine), and it didn't make any difference.

    Funky thing is, with no sleep running, the laptop behaves exactly the same when the external display is attached, that is it'll fall asleep after about 10 seconds when woken by a bluetooth device.

    If I detach the external display and close the lid, the laptop does not fall asleep! I noticed this morning because I was listening to net radio and was packing away my Air to bring it with me. It just kept playing.

    So it seems there's some (very illogical) bug in OS X which makes my laptop insist on sleeping when my external display is attached.

    I find this very very strange :)

    ----------

    It's just such illogical behavior that I can't really believe it's by design. I mean, the logic is that if you're on battery, you have to have the internal display on if you want to use the computer with an external display. In essence by design forcing you to deplete your battery more quickly.

    That must be a bug.
     
  11. DisplacedMic, Jan 15, 2014
    Last edited: Jan 15, 2014

    DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #11
    I will try it out for you when i get home from work. But when you say you "detach the external display and close the lid, the laptop does not fall asleep" do you mean with or without nosleep/caffeine running?


    As to your second point, i understand that it's annoying being "forced" to use it plugged in but i don't think you've characterized the logic quite right. they're not trying to force you to leave both displays on and run down your battery, they want you to plug it in when you're running the TBD or whatever display. you obviously don't have a TBD or you'd be able to plug it in :p

    so theoretically what should happen is if it's hooked up to an external display and running off AC power and you unplug it so that it switches to battery, your computer should sleep whether the lid is open or not. are you saying that's not what's happening?

    i have noticed that sometimes mine will run my TBD not plugged in and sometimes it won't, but it ALWAYS goes to sleep if it's running the TBD while powered and i unplug the magsafe.

    edit: ok - i read your OP a little closer. You plug your laptop into your display and it works fine, but when you close the lid it sleeps.

    like i said, i will play around with this a bit when i get home but i think maybe i've had some "luck" getting it to run my TBD without actually plugging it in. never while in clamshell mode though. this is definitely by design, clamshell mode requires power.

    See the Support Page
     
  12. Johnny McCash thread starter macrumors newbie

    Joined:
    Jul 17, 2013
    #12
    That was with nosleep running :) So even nosleep can't keep the laptop awake with the external screen attached, but without it, it works. Go figure :)

    That doesn't compute. Or what you're saying is, "they want you to not use your computer on battery if you're using an external display, by making the experience really bad and making sure the battery lasts longer". The fact of the matter is that the laptop is running on battery, and that not having the internal display active would make the battery last longer. And therefore neither one of our respective "what they want you to do" makes any sense — which is why I'm saying that it really has to be a bug.

    It reminds me of my now dead Galaxy S II. When it reached 5% battery, it'd automatically turn on the screen with a warning in a dialog with an OK button to tap. Until you tapped the button, the screen would stay on. The exact worst strategy for an almost depleted battery :) That was most definitely a bug, too.

    Well, no, that's not what's happening with the lid open. I'd never expect it to do that. I would expect that to happen with the lid closed, which is also what's happening. But re-waking it via a bluetooth HID — while now running on battery — I wouldn't expect it to put itself to sleep again automatically, and permanently, some ten to twenty seconds later.

    Oh, yes, now I see that my reply above is unneeded :) If this really is by design, it's really really horrible design. I bought an external keyboard because I'm not allowed to turn off the internal display while having an external display attached, and now I find that I'm not even allowed to use it like this without AC power either. It's absolutely horrible! :D Apart from meaning that I now get less battery time when it could mean I got more, it also means I cannot get 24fps playback in XBMC via HDMI without bringing a power adapter...

    That is so retarded. Please let me know if you figure out how you managed to do it on your computer.

    Perhaps I should ask the nosleep devs — it works without an external display, so it seems it oughta work with one as well.

    EDIT: LOL — this is the first request on the issues tracker on nosleep's google code page :D
     

Share This Page