My FireLite portable HD is corrupt ?

Discussion in 'Macintosh Computers' started by Kit Fist0, Mar 10, 2004.

  1. Kit Fist0 macrumors newbie

    Mar 10, 2004
    At school I plugged my 40GB FireLite portable HD into a QuickSilver G4 677Mhz(10.2.8). The computer was acting really slow as it went through my HD. So I held the power button down and restarted it. I had to do this a few times until, it couldn't mount my drive so I took it out of the computer and tried it on a 500Mhz iMac (slot loading)(10.2.8). It gave me a message that I could ignore it or initialize it. So initialize it and I get the Disc Utility. I gave up at this point and went home.

    I tried it on my flower power 500Mhz iMac (slot loading)(10.2.8). It let me verify the disc, but it says that it is fine (???).

    At this point I'm panicking. But can you blame me ?

    Then I plugged it into a 17-inch iMac 1.25Ghz (10.3.2). It let me verify and repair it this time, but I hit repair and it says that it is now repaired. But I still cant access my files. It won't mount my hard drive.

    I called Apple they said they couldn't do anything. All my school work is on the HD so a reformat is out of the question, I should have backed up but it is too late for that. Anyone have any ideas ?
  2. Kit Fist0 thread starter macrumors newbie

    Mar 10, 2004

Share This Page