My iPhone 4S is unresponsive - what to do next?

Discussion in 'iPhone' started by stefek99, Jun 23, 2012.

  1. stefek99 macrumors newbie

    Joined:
    Mar 9, 2012
    #1
    I'm having problems with my iOS device:
    - iPhone4S
    - iOS 5.1.1
    - jailbrake
    - it was locked to Telenor Norway, purchased some activation code on eBay

    2 months it was working fine.
    Yesterday it was working fine.
    This morning it was working fine.
    But right now... See the video:
    http://youtu.be/52mNO7S5u2U


    (trying pressing various buttons with no difference)

    It is unresponsive. Cannot do anything. Maybe you could tell me what to do next?

    (The only thing I managed to do is when connecting to the computer iPhoto launches and asks whether to import photos)

    I will probably leave it to drain the battery, but it may take a while as it is not connected to the network (tried calling = voicemail).
     
  2. MuGeN PoWeR macrumors 68020

    MuGeN PoWeR

    Joined:
    Jun 29, 2011
  3. stefek99 thread starter macrumors newbie

    Joined:
    Mar 9, 2012
    #3
    I don't know what is hard reset but I tried pressing and holding home and lock button for a few seconds... It worked :)

    (I was really panicked that given all circumstances my iDevice is dead)
     
  4. wymi macrumors regular

    Joined:
    Jan 14, 2012
    #4
    Press and hold the power & home buttons until you see the apple logo.
     

Share This Page