My new iMac is faulty... screen lag and grey band on monitor?

Discussion in 'Mac Basics and Help' started by hemmick reef, Sep 2, 2012.

  1. hemmick reef macrumors member

    Joined:
    Sep 2, 2012
    #1
    I have recently jumped ship and moved from a PC to an iMac. I am a freelance Technical Illustrator and use Adobe Illustrator and Photoshop as my main programs.
    I have used the iMac for about a month now and have noticed poor performance when using Adobe Illustrator (screen lag). I contacted Apple Care and they suggested getting in touch with Adobe first. Subsequently I have been in contact several times with Adobe. It has not been resolved. Also I have recently noticed a band of light grey across the bottom of the screen.
    I have now contacted Apple Care again and they believe that there is a hardware fault and it is due to go for an estimated ten day repair.

    At what point will Apple replace a computer if it will cause loss of earnings for a one man, one computer business.

    Has anybody experiences a similar fault?
     
  2. orvn macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #2
    I'm sorry your experience has been so unpleasant. I've had artifacts appear, but only after many years of using a machine.

    Attendants at the genius bar tend to be very reasonable and you have a lot of leverage here, I would pressure them. Especially since they're estimating a two week repair.
     
  3. hemmick reef thread starter macrumors member

    Joined:
    Sep 2, 2012
    #3
    Thanks for the reply.

    I'm going to try and get the iMac replaced as I can't wait ten days for a repair, or my business is going to suffer.
     
  4. hemmick reef thread starter macrumors member

    Joined:
    Sep 2, 2012
    #4
    I've contacted Apple Care again and they are going to replace the computer, since I've had the unresolved issue since I bought it...

    that's what I call good service!
     

Share This Page