My old mbp connects to ftp's & afp's, but my newer one doesn't

Discussion in 'MacBook Pro' started by tomuktomuk, May 18, 2018.

  1. tomuktomuk macrumors newbie

    tomuktomuk

    Joined:
    May 18, 2018
    #1
    I've already had a good look around for a solution to this and haven't seen an existing thread - yet.

    I have a MacBook Pro 11,3 Retina Late 2013 15 inch 2.6 GHz i7 running Yosemite 10.10.5.

    I also have a MacBook Pro 6,2 15-inch Mid 2010 2.66 GHz i7 running Snow Leopard 10.6.8, which I don't really use any more.

    My older on will connect to ftp's or afp's (I had to upload some work to a company's computer using either an afp or ftp and it's uploading via the afp right now.

    My current newer MBP won't connect to ftp's or afp's and I'd like to find out why. When I try it just times out using either method.

    Both have the firewall's turned off. Both are on the same network and accessing the same afp or ftp address.

    I can upload things to the internet (dropbox, email attachments etc.).

    Can anyone suggest something I could try to make my newer one work?
     
  2. psingh01 macrumors 65816

    Joined:
    Apr 19, 2004
    #2
    are you using hostnames or ip addresses to reach these servers?
    is it possible that you have some different settings in your /etc/hosts on both machines? you may have made some settings on your old one and forgot about it. try IP address and see if you can reach it directly.
    do you have any vpn you need to go through to access these servers? is that setup correctly?

    talk to whoever is in charge of the network. not sure if you are at home trying to reach a work computer or at work on a work network. maybe your newer device needs to be registered to access anything there.
     
  3. tomuktomuk thread starter macrumors newbie

    tomuktomuk

    Joined:
    May 18, 2018
    #3
    Hi,

    I'm using the hostname way - I haven't been given the IP address.

    I'm not entirely sure what your second question means - my apologies.

    My guess is that there are some settings in my new machine - or some file or code - that is causing the fault.

    It's possible I've made some changes and forgotten about them - always a possibility I guess.

    I haven't been using a VPN.

    I have spoken to the person who runs the network - they suggested a couple of things, but I've completed the upload on my old machine now, and I don't want to bother them again with the issue.

    I'm at home and was trying to upload a folder of files which is some work for a I did for a company.

    I don't think there's a way to register any device on their network - I just have the ftp or afp address, a user name and a password. Those details worked on my old machine and they suggested that it was all I would need.
     
  4. duervo, May 18, 2018
    Last edited: May 18, 2018

    duervo macrumors 68020

    duervo

    Joined:
    Feb 5, 2011
    #4
    Could be caused by several things, but one of the easiest things to check and fix is:

    Do an nslookup in a terminal window on both systems. They should come back with the same result. If they don’t, then chances are your DNS settings for the newer one are different, and should be changed to match the settings on the older. This could mean either changing them in the system (if IP settings are set manually, or DHCP is set for IP only,) or having your network admin look into the settings for the DHCP server (ie: your newer system could be put into a different scope that has DNS settings that differ from the older system, which might not be doing name resolution properly somewhere, for whatever reason.)

    Other things that cause problems like this are ones such as server side setting allowing connections only from a known IP list or subnet, time being out of sync between client and server, etc. but are much less common.
     

Share This Page