My Powerbook Won't Sleep!!!

Discussion in 'Macintosh Computers' started by vkapoormd, Aug 21, 2004.

  1. vkapoormd macrumors member

    Jun 14, 2004
    San Francisco, CA
    I've noticed the past few days that my PB (G4 15", 1.25 Ghz) won't go to sleep when it is supposed to according to the settings in the Energy Saver in system prefs. I've tried to reapply the settings over and over, but no luck. Only way i get it to sleep is by doing it manually or closing the screen. I have also tried to throw out any corrupted preferences from my user library, but no dice. Oh, more thing, the screen saver works fine, the screen dims appropriately, and the screen itself shuts down fine, but beyond that, won't sleep. Any thoughts would be appreciated... :confused:
  2. mactropy macrumors member


    Dec 4, 2004
    I have the same problem! Maybe someone can help?
    I have a Rev. C PB 12". It's running 10.3.7 . . .
  3. maya macrumors 68040


    Oct 7, 2004
    somewhere between here and there.

    1. Read it a Bed time story.

    2. Give it some sleeping pills.

    3. reduce the sugar or caffeine in take in its diet.

    So I feel like being comedic. :)
  4. Logik macrumors 6502a

    Apr 24, 2004
    make sure when you're in the energy settings thing that you select "plugged in" or "unplugged".. like battery power or whatever... the settings only apply during that situation... just something to check if you haven't already
  5. shecky Guest


    May 24, 2003
    Obviously you're not a golfer.
    i had that problem and it turned out to be some plugin apps for a scanner (the kind that are on waiting for you to hit a button on the scanner to sent to email, etc..) that were always running, preventing the machine from sleeping. go to your activity monitor and look at your processes and see what is running that you can kill.
  6. Mechcozmo macrumors 603


    Jul 17, 2004
    Try repairing your permissions. If they are messed up you can have issues with the machine not being allowed to sleep. I ran into that once, on my dad's Quicksilver. Odd problem...
  7. stephenrydalch macrumors newbie

    Sep 7, 2004
    I had a very similar problem. My powerbook wouldn't go to sleep if my USB 2.0 hub/cooling pad was plugged in. I never figured it out. (even posted a thread here but got no replies.)

    I ended up daisy chaining the same USB hub into another hub for unrelated reasons and that remedied the problem for reasons I don't understand. Maybe it was related to the fact that the signal strength was severly weakened after being run through another hub?

    Hope that helps!

  8. mactropy macrumors member


    Dec 4, 2004
    First of all: thanks for all the advice!!
    I checked my Energy Saver settings and they are configured properly. I also repaired the permissions, which for whatever reason seemed to at least restore the "go to sleep" option when the computer is plugged into the AC adaptor. However, it still doesn't want to sleep when running on battery power.
    I have no external devices installed and also made sure that no programs where running so that these programs would not prevent it from going to sleep.
    Any other advice? (I know I could just reinstall Panther, but I would like to let that be my last resort . . . )
    Thanks again!

Share This Page