NEED HELP!! My CPU is being chewed up...and my activity monitor won't open

Discussion in 'macOS' started by bgill86, Oct 24, 2007.

  1. bgill86 macrumors newbie

    Joined:
    Oct 24, 2007
    #1
    I'm in desperate need of help. I just purchased an Intel MacBook about 2 months ago and have been getting this problem recently:

    1. My CPU is being chewed up by some process. I have iStat Nano and I can clearly see something burning over 50% of my CPU.

    2. I CAN'T OPEN ACTIVITY MONITOR. Every time I try to do so, the program freezes.

    3. Whenever I try to shut down or restart the computer, it will close everything on the desktop and all that will be left is my wallpaper and mouse. And then, it sits there...forever.

    So essentially, I have to manually shut down the computer (which just isn't safe) and my computer's fan is constantly running because my CPU is running harder than it really needs to be. I've already tried to repair disk permissions, and that didn't do anything.

    Anyone have helpful advice?? Thanks in advance.
     
  2. cmaier macrumors G3

    Joined:
    Jul 25, 2007
    Location:
    California
    #2
    Can you run Terminal and type: ps
     
  3. otis123 macrumors 6502a

    Joined:
    May 4, 2006
    #3
    what does that do?
     
  4. Chris F macrumors regular

    Joined:
    Jul 27, 2007
    #4
    Open up a terminal and run: top -o cpu

    It should be pretty obvious from there. :)

    (ps: kill -9 <pid> in another terminal to force terminate a pid in the list)
     
  5. Chris F macrumors regular

    Joined:
    Jul 27, 2007
    #5
    While you are there if you need more help the 'man' command will have documentation for nearly all standard *NIX tools.

    e.g: 'man top' to see other options for the top command
     
  6. bgill86 thread starter macrumors newbie

    Joined:
    Oct 24, 2007
    #6
    No luck :(

    ChrisF:

    I tried what you wrote and had this come up:
    *****-computer:~ ****$ top -o cpu









    And that was it. Just a giant blank space following the command. I tried your command and several other ones as well, but all of them resulted in the same thing. I'm at a loss. Any other ideas??
     
  7. bgill86 thread starter macrumors newbie

    Joined:
    Oct 24, 2007
    #7
    To anyone still interested in this problem...

    I found out that the program that was chewing up the CPU was some script/program involving my HP photosmart printer suite. I simply re-installed the program and that seemed to fix everything. Thanks to everyone for the prompt help!!
     

Share This Page