Need home button doesn’t work and I need to enter DFU mode

Discussion in 'Jailbreaks and iOS Hacks' started by iNassar, Aug 21, 2008.

  1. iNassar macrumors member

    Jun 7, 2008
    My home button just stopped working suddenly, so thinking that it may be software problem (although I think is not very likely) y decided to update it to 2.0 using winpwn. The problem was that when I have to enter DFU mode, I can’t because my home button won’t work. I ’m wondering if there is any other way of entering DFU mode without using the home button or maybe a suggestion for another way to updating to 2.0 without having to enter DFU mode. Also I would appreciate some of your opinions about my home button issue is it hardware or software?
  2. iNassar thread starter macrumors member

    Jun 7, 2008
    I think I may have fixed it

    I have found this method:
    Alternate Method: Going Into DFU Mode Without Button Pushing: (on windows) Easier than timing the buttons just right!

    1.) First download the required archive

    2.) Extract the archive to the root of your hard drive, should be C:/DFU/

    3.) Connect your iPhone and ignore iTunes

    4.) Goto Start - run

    5.) Next type in “c:/dfu/dfu iBSS.m68ap.RELEASE.dfu”

    6.) Wait for iPhone to show a “white” screen

    7.) Now you may proceed to downgrade!

    **also these files are found in ibrickr’s directory except for the .dfu file**

    written by truehybridx

    The problem now is that when I do the restore I get the error "1604"
  3. overbo0st2k4 macrumors newbie

    Sep 16, 2008
    I'm having the same exact issue...

    Only problem is, I'm on a MAC.

    Any idea on how to do this on a MacBook?

  4. DannyBres macrumors 65816


    Oct 30, 2007
    put it in dfu on a friends pc and restore with ur macbook?

    or a neighbours you must know someone close with a pc :p
  5. overbo0st2k4 macrumors newbie

    Sep 16, 2008
    Funny thing...most of my friends have Macs...

    I'll see what I can pull off.

  6. overbo0st2k4 macrumors newbie

    Sep 16, 2008
    I followed these steps precisely, and this is the error I get:

    When I run the command, it says:
    "s_Looking for iPhone
    e_Couldn't pair with iPhone

    Any help is greatly appreciated!

    Thanks in advance.
  7. iNassar thread starter macrumors member

    Jun 7, 2008
    Try it in another usb port or computer. If it still won´t work check your cable it may be damaged. You can also use iLiberty, whch i think it would be better. Check on the advanced tab. I think there is an option for entering DFU mode.
  8. rand0mguy macrumors newbie

    Sep 10, 2009
    I have tried both methods and for the DFU program i got the same response. I also tried everything in the quote and iliberty was not able to put my phone in BFU mode. My iphone is on OS 3.1 and because i cant get into BFU mode i cant down grade either. Any other suggestions?
  9. cdobrow macrumors newbie

    Sep 22, 2009
    The only way to get into dfu mode is by removing the two screws at the bottom of the iphone. Once these are removed you can lift the screen assembly up slightly with a small screw driver. Once its lifted you will see two small rectangle contact points that the home button assembly makes contact with. If you use a small piece of metal and make contact with both of these points the iphone will think you are pressing the home button. Now you can follow the typical method for entering DFU mode, but instead of holding down the home button you will be making contact between those two points. It might take a few tries to get it down, but it works :) good luck!
  10. melvinabundo macrumors newbie

    May 15, 2011
    Thanks cdobrow!

    I've been researching and trying like crazy to get to dfu without a home button. Tried manually changing the insides of the ipsw to force a dfu loop to no avail.

    But your tip on the metal contacts saved my iphone! I'm on 5.0.1 now with no problems. Unlocked too. Now I can get some work done.

    Thanks cdobrow! :)
  11. imthebestcool macrumors newbie

    Jun 10, 2011
    What Metal Tool?

    What metal tool did you used to do this, i really need this and i can't get into my iLhone without the Home Button Cause of iOS 5, Can you describe me what tool and metal pieces you tale and where to put it to make contact and help me to get into DFU mode!

    Thanks A Thousand Time!

Share This Page